Skip to content

← Public intelligence

Maven package

org.webjars.npm:jquery

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedMavenAmendedPublished

    jQuery vulnerable to Cross-Site Scripting (XSS)

    CVE-2011-4969 · GHSA-579v-mp3v-rrw5

    Affected
    • Maven org.webjars.npm:jquery < 1.6.3
    Fixed in
    1.6.3· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.

    Recommended action: Upgrade to 1.6.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1MavenAmendedPublished

    Cross-Site Scripting in jquery

    CVE-2012-6708 · GHSA-2pqj-h3vj-pqgw

    Affected
    • Maven org.webjars.npm:jquery <= 1.8.3
    Fixed in
    1.9.0· Vendor fix available
    Issue
    Affected versions of jquery are vulnerable to cross-site scripting. This occurs because the main jquery function uses a regular expression to differentiate between HTML and selectors, but does not properly anchor the regular expression. The result is that jquery may interpret HTML as selectors when given certain inputs, allowing for client side code execution. Proof of Concept Recommendation Update to version 1.9.0 or later.

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 5.3MavenAmendedPublished

    Cross-Site Scripting in jquery

    CVE-2020-7656 · GHSA-q4m3-2j7h-f7xw

    Affected
    • Maven org.webjars.npm:jquery >= 1.2.1, < 1.9.0
    Fixed in
    1.9.0· Vendor fix available
    Issue
    Versions of jquery prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove <script HTML tags that contain a whitespace character, i.e: </script , which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser. Recommendation Upgrade to version 1.9.0 or later.

    Recommended action: Upgrade to 1.9.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.9Exploited · CISA KEVMavenAmendedPublished

    Potential XSS vulnerability in jQuery

    CVE-2020-11023 · GHSA-jpcq-cgw6-v4j6

    Affected
    • Maven org.webjars.npm:jquery >= 1.0.3, < 3.5.0
    Fixed in
    3.5.0· Vendor fix available
    Issue
    Impact Passing HTML containing <option elements from untrusted sources - even after sanitizing them - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround this issue without upgrading, use DOMPurify with its SAFEFORJQUERY option to sanitize the HTML string before passing it to a jQuery method. References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.

    Recommended action: Upgrade to 3.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)cisa.gov (2)github.com (3)cisa.gov (4)Source checked Evidence →
  5. Medium, CVSS 6.9MavenAmendedPublished

    Potential XSS vulnerability in jQuery

    CVE-2020-11022 · GHSA-gxr4-xjj5-5px2

    Affected
    • Maven org.webjars.npm:jquery >= 1.12.0, < 3.5.0
    Fixed in
    3.5.0· Vendor fix available
    Issue
    Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround the issue without upgrading, adding the following to your code: You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround. References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.

    Recommended action: Upgrade to 3.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.1MavenAmendedPublished

    XSS in jQuery as used in Drupal, Backdrop CMS, and other products

    CVE-2019-11358 · GHSA-6c3j-c64m-qhgq

    Affected
    • Maven org.webjars.npm:jquery >= 1.1.4, < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    jQuery from 1.1.4 until 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable proto property, it could extend the native Object.prototype.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. High, CVSS 7.5MavenAmendedPublished

    Denial of Service in jquery

    CVE-2016-10707 · GHSA-mhpp-875w-9cpv

    Affected
    • Maven org.webjars.npm:jquery >= 3.0.0-rc1, <= 3.0.0-rc1
    Fixed in
    3.0.0· Vendor fix available
    Issue
    Affected versions of jquery use a lowercasing logic on attribute names. When given a boolean attribute with a name that contains uppercase characters, jquery enters into an infinite recursion loop, exceeding the call stack limit, and resulting in a denial of service condition. Recommendation Update to version 3.0.0 or later.

    Recommended action: Upgrade to 3.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. Medium, CVSS 6.1MavenAmendedPublished

    Cross-Site Scripting (XSS) in jquery

    CVE-2015-9251 · GHSA-rmxg-73gg-4p98

    Affected
    • Maven org.webjars.npm:jquery < 1.12.2; >= 1.12.3, < 3.0.0
    Fixed in
    1.12.23.0.0· Vendor fix available
    Issue
    Affected versions of jquery interpret text/javascript responses from cross-origin ajax requests, and automatically execute the contents in jQuery.globalEval, even when the ajax request doesn't contain the dataType option. Recommendation Update to version 3.0.0 or later.

    Recommended action: Upgrade to 3.0.0 or 1.12.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →