Skip to content

← Actionable
Medium, CVSS 6.9Exploited · CISA KEVamended

Potential XSS vulnerability in jQuery

CVE-2020-11023GHSA-jpcq-cgw6-v4j6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 3.5.0; components/jquery 3.5.0; jquery 3.5.0; org.webjars.npm:jquery 3.5.0; jquery-rails 4.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
CVSS
6.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N/E:H
EPSS
  • CVE-2020-11023: 84.89% estimated exploitation activity in the next 30 days; percentile 99.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Passing HTML containing <option elements from untrusted sources - even after sanitizing them - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround this issue without upgrading, use DOMPurify with its SAFEFORJQUERY option to sanitize the HTML string before passing it to a jQuery method. References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-jpcq-cgw6-v4j6

  2. Revision 2 · evidence added ·

    CISA KEV confirmed exploitation for CVE-2020-11023 (date added 2025-01-23). Customer workflow unchanged.

  3. Revision 1 · created ·

    Published from osv record GHSA-jpcq-cgw6-v4j6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-11023

Advisory: Potential XSS vulnerability in jQuery
IDs: CVE-2020-11023, GHSA-jpcq-cgw6-v4j6
Record: https://patchnext.com/advisories/cve-2020-11023 (revision 3, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Vendor fix available; fixed versions by package: jquery 3.5.0; components/jquery 3.5.0; jquery 3.5.0; org.webjars.npm:jquery 3.5.0; jquery-rails 4.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet jquery: affected >= 1.0.3, < 3.5.0; fixed in 3.5.0
- Packagist components/jquery: affected >= 1.0.3, < 3.5.0; fixed in 3.5.0
- npm jquery: affected >= 1.0.3, < 3.5.0; fixed in 3.5.0
- Maven org.webjars.npm:jquery: affected >= 1.0.3, < 3.5.0; fixed in 3.5.0
- RubyGems jquery-rails: affected < 4.4.0; fixed in 4.4.0

## Suggested inspection (read-only)
- NuGet jquery: check the installed version with your package manager.
- Packagist components/jquery: check the installed version with your package manager.
- `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Maven org.webjars.npm:jquery: check the installed version with your package manager.
- RubyGems jquery-rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jquery, components/jquery, org.webjars.npm:jquery, jquery-rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jpcq-cgw6-v4j6 (OSV record GHSA-jpcq-cgw6-v4j6 lists affected ranges: npm jquery >=1.0.3 =0 =1.0.3 =1.0.3 =1.0.3 <3.5.0 (fixed))
- Verified: https://www.cisa.gov/sites/default/files/feeds/known_exploited_vulnerabilities.json (CISA added CVE-2020-11023 to the Known Exploited Vulnerabilities catalog on 2025-01-23.)
- Verified: https://github.com/advisories/GHSA-jpcq-cgw6-v4j6 (GitHub-reviewed advisory GHSA-jpcq-cgw6-v4j6 lists affected ranges: npm jquery >=1.0.3 =0 =1.0.3 =1.0.3 =1.0.3 <3.5.0)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2020-11023 to the Known Exploited Vulnerabilities catalog on 2025-01-23.)

Commands are suggestions: review each one before running it.

Loading voting…