Cross-Site Scripting in jquery
CVE-2020-7656GHSA-q4m3-2j7h-f7xw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 1.9.0; jquery 1.9.0; org.webjars.npm:jquery 1.9.0; jquery-rails 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet jquery
- Affected
- >= 1.2.1, < 1.9.0
- Fixed in
- 1.9.0
npm jquery
- Affected
- >= 1.2.1, < 1.9.0
- Fixed in
- 1.9.0
Maven org.webjars.npm:jquery
- Affected
- >= 1.2.1, < 1.9.0
- Fixed in
- 1.9.0
RubyGems jquery-rails
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q4m3-2j7h-f7xw lists affected ranges: npm jquery >=1.2.1 =1.2.1 =0 =1.2.1 <1.9.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q4m3-2j7h-f7xw lists affected ranges: RubyGems jquery-rails >=0 =1.2.1 =1.2.1 =1.2.1 <1.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2020-7656: 6.43% estimated exploitation activity in the next 30 days; percentile 93.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of jquery prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove <script HTML tags that contain a whitespace character, i.e: </script , which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser. Recommendation Upgrade to version 1.9.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-q4m3-2j7h-f7xw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-q4m3-2j7h-f7xw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-7656 Advisory: Cross-Site Scripting in jquery IDs: CVE-2020-7656, GHSA-q4m3-2j7h-f7xw Record: https://patchnext.com/advisories/cve-2020-7656 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jquery 1.9.0; jquery 1.9.0; org.webjars.npm:jquery 1.9.0; jquery-rails 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet jquery: affected >= 1.2.1, < 1.9.0; fixed in 1.9.0 - npm jquery: affected >= 1.2.1, < 1.9.0; fixed in 1.9.0 - Maven org.webjars.npm:jquery: affected >= 1.2.1, < 1.9.0; fixed in 1.9.0 - RubyGems jquery-rails: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - NuGet jquery: check the installed version with your package manager. - `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Maven org.webjars.npm:jquery: check the installed version with your package manager. - RubyGems jquery-rails: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jquery, org.webjars.npm:jquery, jquery-rails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q4m3-2j7h-f7xw (OSV record GHSA-q4m3-2j7h-f7xw lists affected ranges: npm jquery >=1.2.1 =1.2.1 =0 =1.2.1 <1.9.0 (fixed)) - Verified: https://github.com/advisories/GHSA-q4m3-2j7h-f7xw (GitHub-reviewed advisory GHSA-q4m3-2j7h-f7xw lists affected ranges: RubyGems jquery-rails >=0 =1.2.1 =1.2.1 =1.2.1 <1.9.0) Commands are suggestions: review each one before running it.
Loading voting…