Potential XSS vulnerability in jQuery
CVE-2020-11022GHSA-gxr4-xjj5-5px2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 3.5.0; components/jquery 3.5.0; jquery 3.5.0; athlon1600/youtube-downloader 4.0.1; org.webjars.npm:jquery 3.5.0; 2 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet jquery
- Affected
- >= 1.12.0, < 3.5.0
- Fixed in
- 3.5.0
Packagist components/jquery
- Affected
- >= 1.12.0, < 3.5.0
- Fixed in
- 3.5.0
npm jquery
- Affected
- >= 1.12.0, < 3.5.0
- Fixed in
- 3.5.0
Packagist athlon1600/youtube-downloader
- Affected
- <= 4.0.0
- Fixed in
- 4.0.1
Maven org.webjars.npm:jquery
- Affected
- >= 1.12.0, < 3.5.0
- Fixed in
- 3.5.0
RubyGems jquery-rails
- Affected
- < 4.4.0
- Fixed in
- 4.4.0
Packagist maximebf/debugbar
- Affected
- < 1.19.0
- Fixed in
- 1.19.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gxr4-xjj5-5px2 lists affected ranges: npm jquery >=1.12.0 =1.12.0 =0 =1.12.0 =0 =0 =1.12.0 <3.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gxr4-xjj5-5px2 lists affected ranges: RubyGems jquery-rails >=0 =0 =0 =1.12.0 =1.12.0 =1.12.0 =1.12.0 <3.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:N
- EPSS
- CVE-2020-11022: 99.22% estimated exploitation activity in the next 30 days; percentile 99.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround the issue without upgrading, adding the following to your code: You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround. References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gxr4-xjj5-5px2
- Revision 1 · created ·
Published from osv record GHSA-gxr4-xjj5-5px2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-11022 Advisory: Potential XSS vulnerability in jQuery IDs: CVE-2020-11022, GHSA-gxr4-xjj5-5px2 Record: https://patchnext.com/advisories/cve-2020-11022 (revision 2, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jquery 3.5.0; components/jquery 3.5.0; jquery 3.5.0; athlon1600/youtube-downloader 4.0.1; org.webjars.npm:jquery 3.5.0; jquery-rails 4.4.0; maximebf/debugbar 1.19.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet jquery: affected >= 1.12.0, < 3.5.0; fixed in 3.5.0 - Packagist components/jquery: affected >= 1.12.0, < 3.5.0; fixed in 3.5.0 - npm jquery: affected >= 1.12.0, < 3.5.0; fixed in 3.5.0 - Packagist athlon1600/youtube-downloader: affected <= 4.0.0; fixed in 4.0.1 - Maven org.webjars.npm:jquery: affected >= 1.12.0, < 3.5.0; fixed in 3.5.0 - RubyGems jquery-rails: affected < 4.4.0; fixed in 4.4.0 - Packagist maximebf/debugbar: affected < 1.19.0; fixed in 1.19.0 ## Suggested inspection (read-only) - NuGet jquery: check the installed version with your package manager. - Packagist components/jquery: check the installed version with your package manager. - `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Packagist athlon1600/youtube-downloader: check the installed version with your package manager. - Maven org.webjars.npm:jquery: check the installed version with your package manager. - RubyGems jquery-rails: check the installed version with your package manager. - Packagist maximebf/debugbar: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jquery, components/jquery, athlon1600/youtube-downloader, org.webjars.npm:jquery, jquery-rails, maximebf/debugbar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gxr4-xjj5-5px2 (OSV record GHSA-gxr4-xjj5-5px2 lists affected ranges: npm jquery >=1.12.0 =1.12.0 =0 =1.12.0 =0 =0 =1.12.0 <3.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-gxr4-xjj5-5px2 (GitHub-reviewed advisory GHSA-gxr4-xjj5-5px2 lists affected ranges: RubyGems jquery-rails >=0 =0 =0 =1.12.0 =1.12.0 =1.12.0 =1.12.0 <3.5.0) Commands are suggestions: review each one before running it.
Loading voting…