Medium, CVSS 6.9PackagistAmendedPublished
Potential XSS vulnerability in jQuery
CVE-2020-11022 · GHSA-gxr4-xjj5-5px2
- Affected
- Packagist athlon1600/youtube-downloader <= 4.0.0
- Fixed in
- 4.0.1· Vendor fix available
- Issue
- Impact Passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. Patches This problem is patched in jQuery 3.5.0. Workarounds To workaround the issue without upgrading, adding the following to your code: You need to use at least jQuery 1.12/2.2 or newer to be able to apply this workaround. References https://blog.jquery.com/2020/04/10/jquery-3-5-0-released/ https://jquery.com/upgrade-guide/3.5/ For more information If you have any questions or comments about this advisory, search for a relevant issue in the jQuery repo. If you don't find an answer, open a new issue.
Recommended action: Upgrade to 4.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.