Skip to content

← Actionable
High, CVSS 7.5amended

Denial of Service in jquery

CVE-2016-10707GHSA-mhpp-875w-9cpv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 3.0.0; jquery 3.0.0; org.webjars.npm:jquery 3.0.0; jquery-rails 3.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet jquery

    Affected
    >= 3.0.0-rc.1, <= 3.0.0-rc.1
    Fixed in
    3.0.0
  • npm jquery

    Affected
    >= 3.0.0-rc.1, <= 3.0.0-rc.1
    Fixed in
    3.0.0
  • Maven org.webjars.npm:jquery

    Affected
    >= 3.0.0-rc1, <= 3.0.0-rc1
    Fixed in
    3.0.0
  • RubyGems jquery-rails

    Affected
    >= 3.0.0-rc.1, <= 3.0.0-rc.1
    Fixed in
    3.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2016-10707: 3.23% estimated exploitation activity in the next 30 days; percentile 88.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of jquery use a lowercasing logic on attribute names. When given a boolean attribute with a name that contains uppercase characters, jquery enters into an infinite recursion loop, exceeding the call stack limit, and resulting in a denial of service condition. Recommendation Update to version 3.0.0 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mhpp-875w-9cpv

  2. Revision 1 · created ·

    Published from osv record GHSA-mhpp-875w-9cpv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2016-10707

Advisory: Denial of Service in jquery
IDs: CVE-2016-10707, GHSA-mhpp-875w-9cpv
Record: https://patchnext.com/advisories/cve-2016-10707 (revision 2, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jquery 3.0.0; jquery 3.0.0; org.webjars.npm:jquery 3.0.0; jquery-rails 3.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet jquery: affected >= 3.0.0-rc.1, <= 3.0.0-rc.1; fixed in 3.0.0
- npm jquery: affected >= 3.0.0-rc.1, <= 3.0.0-rc.1; fixed in 3.0.0
- Maven org.webjars.npm:jquery: affected >= 3.0.0-rc1, <= 3.0.0-rc1; fixed in 3.0.0
- RubyGems jquery-rails: affected >= 3.0.0-rc.1, <= 3.0.0-rc.1; fixed in 3.0.0

## Suggested inspection (read-only)
- NuGet jquery: check the installed version with your package manager.
- `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- Maven org.webjars.npm:jquery: check the installed version with your package manager.
- RubyGems jquery-rails: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jquery, org.webjars.npm:jquery, jquery-rails.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mhpp-875w-9cpv (OSV record GHSA-mhpp-875w-9cpv lists affected ranges: npm jquery >=3.0.0-rc.1 =3.0.0-rc.1 =3.0.0-rc1 =3.0.0-rc.1 <3.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mhpp-875w-9cpv (GitHub-reviewed advisory GHSA-mhpp-875w-9cpv lists affected ranges: npm jquery >=3.0.0-rc.1 =3.0.0-rc.1 =3.0.0-rc.1 =3.0.0-rc1 <=3.0.0-rc1)

Commands are suggestions: review each one before running it.

Loading voting…