Cross-Site Scripting in jquery
CVE-2012-6708GHSA-2pqj-h3vj-pqgw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 1.9.0; jquery 1.9.0; org.webjars.npm:jquery 1.9.0; jquery-rails 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet jquery
- Affected
- <= 1.8.3
- Fixed in
- 1.9.0
npm jquery
- Affected
- <= 1.8.3
- Fixed in
- 1.9.0
Maven org.webjars.npm:jquery
- Affected
- <= 1.8.3
- Fixed in
- 1.9.0
RubyGems jquery-rails
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2pqj-h3vj-pqgw lists affected ranges: npm jquery >=0 =0 =0 =0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2pqj-h3vj-pqgw lists affected ranges: npm jquery >=0 =0 =0 =0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2012-6708: 8.63% estimated exploitation activity in the next 30 days; percentile 95.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of jquery are vulnerable to cross-site scripting. This occurs because the main jquery function uses a regular expression to differentiate between HTML and selectors, but does not properly anchor the regular expression. The result is that jquery may interpret HTML as selectors when given certain inputs, allowing for client side code execution. Proof of Concept Recommendation Update to version 1.9.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2pqj-h3vj-pqgw
- Revision 1 · created ·
Published from osv record GHSA-2pqj-h3vj-pqgw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-6708 Advisory: Cross-Site Scripting in jquery IDs: CVE-2012-6708, GHSA-2pqj-h3vj-pqgw Record: https://patchnext.com/advisories/cve-2012-6708 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jquery 1.9.0; jquery 1.9.0; org.webjars.npm:jquery 1.9.0; jquery-rails 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet jquery: affected <= 1.8.3; fixed in 1.9.0 - npm jquery: affected <= 1.8.3; fixed in 1.9.0 - Maven org.webjars.npm:jquery: affected <= 1.8.3; fixed in 1.9.0 - RubyGems jquery-rails: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - NuGet jquery: check the installed version with your package manager. - `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Maven org.webjars.npm:jquery: check the installed version with your package manager. - RubyGems jquery-rails: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jquery, org.webjars.npm:jquery, jquery-rails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2pqj-h3vj-pqgw (OSV record GHSA-2pqj-h3vj-pqgw lists affected ranges: npm jquery >=0 =0 =0 =0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-2pqj-h3vj-pqgw (GitHub-reviewed advisory GHSA-2pqj-h3vj-pqgw lists affected ranges: npm jquery >=0 =0 =0 =0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…