jQuery vulnerable to Cross-Site Scripting (XSS)
CVE-2011-4969GHSA-579v-mp3v-rrw5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 1.6.3; jquery 1.6.3; org.webjars.npm:jquery 1.6.3; jquery-rails 1.0.16), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet jquery
- Affected
- < 1.6.3
- Fixed in
- 1.6.3
npm jquery
- Affected
- < 1.6.3
- Fixed in
- 1.6.3
Maven org.webjars.npm:jquery
- Affected
- < 1.6.3
- Fixed in
- 1.6.3
RubyGems jquery-rails
- Affected
- < 1.0.16
- Fixed in
- 1.0.16
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-579v-mp3v-rrw5 lists affected ranges: npm jquery >=0 =0 =0 =0 <1.6.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-579v-mp3v-rrw5 lists affected ranges: npm jquery >=0 =0 =0 =0 <1.6.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2011-4969: 19.19% estimated exploitation activity in the next 30 days; percentile 97.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to inject arbitrary web script or HTML via a crafted tag.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-579v-mp3v-rrw5
- Revision 1 · created ·
Published from osv record GHSA-579v-mp3v-rrw5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2011-4969 Advisory: jQuery vulnerable to Cross-Site Scripting (XSS) IDs: CVE-2011-4969, GHSA-579v-mp3v-rrw5 Record: https://patchnext.com/advisories/cve-2011-4969 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jquery 1.6.3; jquery 1.6.3; org.webjars.npm:jquery 1.6.3; jquery-rails 1.0.16. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet jquery: affected < 1.6.3; fixed in 1.6.3 - npm jquery: affected < 1.6.3; fixed in 1.6.3 - Maven org.webjars.npm:jquery: affected < 1.6.3; fixed in 1.6.3 - RubyGems jquery-rails: affected < 1.0.16; fixed in 1.0.16 ## Suggested inspection (read-only) - NuGet jquery: check the installed version with your package manager. - `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Maven org.webjars.npm:jquery: check the installed version with your package manager. - RubyGems jquery-rails: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jquery, org.webjars.npm:jquery, jquery-rails. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-579v-mp3v-rrw5 (OSV record GHSA-579v-mp3v-rrw5 lists affected ranges: npm jquery >=0 =0 =0 =0 <1.6.3 (fixed)) - Verified: https://github.com/advisories/GHSA-579v-mp3v-rrw5 (GitHub-reviewed advisory GHSA-579v-mp3v-rrw5 lists affected ranges: npm jquery >=0 =0 =0 =0 <1.6.3) Commands are suggestions: review each one before running it.
Loading voting…