XSS in jQuery as used in Drupal, Backdrop CMS, and other products
CVE-2019-11358GHSA-6c3j-c64m-qhgq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jquery 3.4.0; django 2.2.2, 2.1.9; jquery 3.4.0; org.webjars.npm:jquery 3.4.0; jquery-rails 4.3.4; 1 more package under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet jquery
- Affected
- >= 1.1.4, < 3.4.0
- Fixed in
- 3.4.0
PyPI django
- Affected
- >= 2.0a1, < 2.1.9>= 2.2a1, < 2.2.2
- Fixed in
- 2.2.2, 2.1.9
npm jquery
- Affected
- >= 1.1.4, < 3.4.0
- Fixed in
- 3.4.0
Maven org.webjars.npm:jquery
- Affected
- >= 1.1.4, < 3.4.0
- Fixed in
- 3.4.0
RubyGems jquery-rails
- Affected
- < 4.3.4
- Fixed in
- 4.3.4
Packagist maximebf/debugbar
- Affected
- < 1.19.0
- Fixed in
- 1.19.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6c3j-c64m-qhgq lists affected ranges: npm jquery >=1.1.4 =0 =1.1.4 =2.0a1 =2.2a1 =1.1.4 =0 <1.19.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6c3j-c64m-qhgq lists affected ranges: RubyGems jquery-rails >=0 =2.0a1 =2.2a1 =1.1.4 =1.1.4 =1.1.4 =0 <1.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2019-11358: 86.82% estimated exploitation activity in the next 30 days; percentile 99.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
jQuery from 1.1.4 until 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of Object.prototype pollution. If an unsanitized source object contained an enumerable proto property, it could extend the native Object.prototype.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6c3j-c64m-qhgq
- Revision 1 · created ·
Published from osv record GHSA-6c3j-c64m-qhgq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-11358 Advisory: XSS in jQuery as used in Drupal, Backdrop CMS, and other products IDs: CVE-2019-11358, GHSA-6c3j-c64m-qhgq Record: https://patchnext.com/advisories/cve-2019-11358 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jquery 3.4.0; django 2.2.2, 2.1.9; jquery 3.4.0; org.webjars.npm:jquery 3.4.0; jquery-rails 4.3.4; maximebf/debugbar 1.19.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet jquery: affected >= 1.1.4, < 3.4.0; fixed in 3.4.0 - PyPI django: affected >= 2.0a1, < 2.1.9; >= 2.2a1, < 2.2.2; fixed in 2.2.2, 2.1.9 - npm jquery: affected >= 1.1.4, < 3.4.0; fixed in 3.4.0 - Maven org.webjars.npm:jquery: affected >= 1.1.4, < 3.4.0; fixed in 3.4.0 - RubyGems jquery-rails: affected < 4.3.4; fixed in 4.3.4 - Packagist maximebf/debugbar: affected < 1.19.0; fixed in 1.19.0 ## Suggested inspection (read-only) - NuGet jquery: check the installed version with your package manager. - `python -m pip show django`: prints the installed version. Run with the environment that serves production active. - `npm ls jquery --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Maven org.webjars.npm:jquery: check the installed version with your package manager. - RubyGems jquery-rails: check the installed version with your package manager. - Packagist maximebf/debugbar: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jquery, django, org.webjars.npm:jquery, jquery-rails, maximebf/debugbar. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6c3j-c64m-qhgq (OSV record GHSA-6c3j-c64m-qhgq lists affected ranges: npm jquery >=1.1.4 =0 =1.1.4 =2.0a1 =2.2a1 =1.1.4 =0 <1.19.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6c3j-c64m-qhgq (GitHub-reviewed advisory GHSA-6c3j-c64m-qhgq lists affected ranges: RubyGems jquery-rails >=0 =2.0a1 =2.2a1 =1.1.4 =1.1.4 =1.1.4 =0 <1.19.0) Commands are suggestions: review each one before running it.
Loading voting…