Skip to content

← Public intelligence

PyPI package

cinder

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

8 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.7PyPIAmendedPublished

    OpenStack Cinder, glance, and Nova vulnerable to Path Traversal

    CVE-2022-47951 · GHSA-7h75-hwxx-qpgc

    Affected
    • PyPI cinder < 19.1.2; >= 20.0.0, < 20.0.2
    Fixed in
    20.0.219.1.2· Vendor fix available
    Issue
    An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and Nova before 24.1.2, 25.x before 25.0.2, and 26.0.0. By supplying a specially created VMDK flat image that references a specific backing file path, an authenticated user may convince systems to return a copy of that file's contents from the server, resulting in unauthorized access to potentially sensitive data.

    Recommended action: Upgrade to 20.0.2 or 19.1.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.1PyPIAmendedPublished

    Openstack cinder Improper handling of ScaleIO backend credentials

    CVE-2020-10755 · GHSA-v3m2-pg96-w33m

    Affected
    • PyPI cinder >= 14.0.0, < 14.1.0; >= 15.0.0, < 15.2.0; >= 16.0.0, < 16.1.0
    Fixed in
    16.1.014.1.015.2.0· Vendor fix available
    Issue
    An insecure-credentials flaw was found in all openstack-cinder versions before openstack-cinder 14.1.0, all openstack-cinder 15.x.x versions before openstack-cinder 15.2.0 and all openstack-cinder 16.x.x versions before openstack-cinder 16.1.0. When using openstack-cinder with the Dell EMC ScaleIO or VxFlex OS backend storage driver, credentials for the entire backend are exposed in the connectioninfo element in all Block Storage v3 Attachments API calls containing that element. This flaw enables an end-user to create a volume, make an API call to show the attachment detail information, and retrieve a username and password that may be used to connect to another user's volume. Additionally, these credentials are valid for the ScaleIO or VxFlex OS Management API, should an attacker discover the Management API endpoint. Source: OpenStack project

    Recommended action: Upgrade to 16.1.0, 15.2.0 or 14.1.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.9PyPIAmendedPublished

    OpenStack Cinder LVMVolumeDriver does not zero deleted snapshots

    CVE-2013-4183 · GHSA-q3rw-wcj6-8cjf

    Affected
    • PyPI cinder < 7.0.0a0
    Fixed in
    7.0.0a0· Vendor fix available
    Issue
    The clearvolume function in LVMVolumeDriver driver in OpenStack Cinder 2013.1.1 through 2013.1.2 does not properly clear data when deleting a snapshot, which allows local users to obtain sensitive information via unspecified vectors.

    Recommended action: Upgrade to 7.0.0a0 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. UnratedPyPIAmendedPublished

    OpenStack Cinder Exposure of Sensitive Information to an Unauthorized Actor vulnerability

    CVE-2014-3641 · GHSA-qhch-g8qr-p497

    Affected
    • PyPI cinder < 2014.1.3
    Fixed in
    2014.1.3· Vendor fix available
    Issue
    The (1) GlusterFS and (2) Linux Smbfs drivers in OpenStack Cinder before 2014.1.3 allows remote authenticated users to obtain file data from the Cinder-volume host by cloning and attaching a volume with a crafted qcow2 header.

    Recommended action: Upgrade to 2014.1.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. UnratedPyPIAmendedPublished

    OpenStack Cinder file disclosure in image convert

    CVE-2015-1851 · GHSA-9hcj-h2qc-689p

    Affected
    • PyPI cinder < 7.0.0a0
    Fixed in
    7.0.0a0· Vendor fix available
    Issue
    OpenStack Cinder before 2014.1.5 (icehouse), 2014.2.x before 2014.2.4 (juno), and 2015.1.x before 2015.1.1 (kilo) allows remote authenticated users to read arbitrary files via a crafted qcow2 signature in an image to the upload-to-image command.

    Recommended action: Upgrade to 7.0.0a0 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. High, CVSS 7.5PyPIAmendedPublished

    OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption

    CVE-2015-5162 · GHSA-g2j5-7vgx-6xrx

    Affected
    • PyPI cinder < 7.0.2; >= 8.0.0, < 9.0.0
    Fixed in
    9.0.07.0.2· Vendor fix available
    Issue
    The image parser in OpenStack Cinder prior to 7.0.2, and 8.0.0 and above, prior to 9.0.0; Glance prior to 14.00; and Nova prior to 12.0.4 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image. This issue is patched in Cinder 7.0.2 and 9.0.0; Glance 14.0.0; and Nova 12.0.4

    Recommended action: Upgrade to 9.0.0 or 7.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. UnratedPyPIAmendedPublished

    OpenStack Cinder Denial of Service using XML entities

    CVE-2013-4202 · GHSA-mfg4-9xf4-f45q

    Affected
    • PyPI cinder < 7.0.0a0
    Fixed in
    7.0.0a0· Vendor fix available
    Issue
    The (1) backup (api/contrib/backups.py) and (2) volume transfer (contrib/volumetransfer.py) APIs in OpenStack Cinder Grizzly 2013.1.3 and earlier allows remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack. NOTE: this issue is due to an incomplete fix for CVE-2013-1664.

    Recommended action: Upgrade to 7.0.0a0 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  8. Medium, CVSS 5.9PyPIAmendedPublished

    OpenStack Keystone and other components vulnerable to Improper Certificate Validation

    CVE-2013-2255 · GHSA-qh2x-hpf9-cf2g

    Affected
    • PyPI cinder < 7.0.0a0
    Fixed in
    7.0.0a0· Vendor fix available
    Issue
    HTTPSConnections in OpenStack Keystone 2013, OpenStack Compute 2013.1, and possibly other OpenStack components, fail to validate server-side SSL certificates.

    Recommended action: Upgrade to 7.0.0a0 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →