OpenStack Cinder, glance, and Nova vulnerable to Path Traversal
CVE-2022-47951GHSA-7h75-hwxx-qpgc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nova 25.0.2, 24.1.2; glance 24.1.1, 23.0.1; cinder 20.0.2, 19.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7h75-hwxx-qpgc lists affected ranges: PyPI cinder >=0 =20.0.0 =0 =24.0.0 =0 =25.0.0 <25.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7h75-hwxx-qpgc lists affected ranges: PyPI cinder >=0 =20.0.0 =0 =24.0.0 =0 =25.0.0 <25.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-47951: 1.03% estimated exploitation activity in the next 30 days; percentile 63.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in OpenStack Cinder before 19.1.2, 20.x before 20.0.2, and 21.0.0; Glance before 23.0.1, 24.x before 24.1.1, and 25.0.0; and Nova before 24.1.2, 25.x before 25.0.2, and 26.0.0. By supplying a specially created VMDK flat image that references a specific backing file path, an authenticated user may convince systems to return a copy of that file's contents from the server, resulting in unauthorized access to potentially sensitive data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7h75-hwxx-qpgc
- Revision 1 · created ·
Published from osv record GHSA-7h75-hwxx-qpgc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-47951 Advisory: OpenStack Cinder, glance, and Nova vulnerable to Path Traversal IDs: CVE-2022-47951, GHSA-7h75-hwxx-qpgc Record: https://patchnext.com/advisories/cve-2022-47951 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nova 25.0.2, 24.1.2; glance 24.1.1, 23.0.1; cinder 20.0.2, 19.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nova: affected < 24.1.2; >= 25.0.0, < 25.0.2; fixed in 24.1.2, 25.0.2 - PyPI glance: affected < 23.0.1; >= 24.0.0, < 24.1.1; fixed in 24.1.1, 23.0.1 - PyPI cinder: affected < 19.1.2; >= 20.0.0, < 20.0.2; fixed in 20.0.2, 19.1.2 ## Suggested inspection (read-only) - `python -m pip show nova`: prints the installed version. Run with the environment that serves production active. - `python -m pip show glance`: prints the installed version. Run with the environment that serves production active. - `python -m pip show cinder`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nova, glance, cinder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7h75-hwxx-qpgc (OSV record GHSA-7h75-hwxx-qpgc lists affected ranges: PyPI cinder >=0 =20.0.0 =0 =24.0.0 =0 =25.0.0 <25.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7h75-hwxx-qpgc (GitHub-reviewed advisory GHSA-7h75-hwxx-qpgc lists affected ranges: PyPI cinder >=0 =20.0.0 =0 =24.0.0 =0 =25.0.0 <25.0.2) Commands are suggestions: review each one before running it.
Loading voting…