Skip to content

← Actionable
High, CVSS 7.5amended

OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption

CVE-2015-5162GHSA-g2j5-7vgx-6xrx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nova 12.0.4; glance 14.0.0; cinder 9.0.0, 7.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nova

    Affected
    < 12.0.4
    Fixed in
    12.0.4
  • PyPI glance

    Affected
    < 14.0.0
    Fixed in
    14.0.0
  • PyPI cinder

    Affected
    < 7.0.2>= 8.0.0, < 9.0.0
    Fixed in
    9.0.0, 7.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2015-5162: 3.09% estimated exploitation activity in the next 30 days; percentile 87.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The image parser in OpenStack Cinder prior to 7.0.2, and 8.0.0 and above, prior to 9.0.0; Glance prior to 14.00; and Nova prior to 12.0.4 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image. This issue is patched in Cinder 7.0.2 and 9.0.0; Glance 14.0.0; and Nova 12.0.4

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g2j5-7vgx-6xrx

  2. Revision 1 · created ·

    Published from osv record GHSA-g2j5-7vgx-6xrx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-5162

Advisory: OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption
IDs: CVE-2015-5162, GHSA-g2j5-7vgx-6xrx
Record: https://patchnext.com/advisories/cve-2015-5162 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nova 12.0.4; glance 14.0.0; cinder 9.0.0, 7.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nova: affected < 12.0.4; fixed in 12.0.4
- PyPI glance: affected < 14.0.0; fixed in 14.0.0
- PyPI cinder: affected < 7.0.2; >= 8.0.0, < 9.0.0; fixed in 9.0.0, 7.0.2

## Suggested inspection (read-only)
- `python -m pip show nova`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show glance`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show cinder`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nova, glance, cinder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g2j5-7vgx-6xrx (OSV record GHSA-g2j5-7vgx-6xrx lists affected ranges: PyPI cinder >=0 =8.0.0 =0 =0 <12.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-g2j5-7vgx-6xrx (GitHub-reviewed advisory GHSA-g2j5-7vgx-6xrx lists affected ranges: PyPI cinder >=0 =8.0.0 =0 =0 <12.0.4)

Commands are suggestions: review each one before running it.

Loading voting…