OpenStack Keystone and other components vulnerable to Improper Certificate Validation
CVE-2013-2255GHSA-qh2x-hpf9-cf2g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-keystoneclient 0.4.0; neutron 7.0.0a0; cinder 7.0.0a0; keystone 8.0.0a0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-qh2x-hpf9-cf2g lists affected ranges: PyPI python-keystoneclient >=0 =0 =0 =0 <8.0.0a0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qh2x-hpf9-cf2g lists affected ranges: PyPI python-keystoneclient >=0 =0 =0 =0 <8.0.0a0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2013-2255: 0.97% estimated exploitation activity in the next 30 days; percentile 61.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HTTPSConnections in OpenStack Keystone 2013, OpenStack Compute 2013.1, and possibly other OpenStack components, fail to validate server-side SSL certificates.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-qh2x-hpf9-cf2g
- Revision 1 · created ·
Published from osv record GHSA-qh2x-hpf9-cf2g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-2255 Advisory: OpenStack Keystone and other components vulnerable to Improper Certificate Validation IDs: CVE-2013-2255, GHSA-qh2x-hpf9-cf2g Record: https://patchnext.com/advisories/cve-2013-2255 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: python-keystoneclient 0.4.0; neutron 7.0.0a0; cinder 7.0.0a0; keystone 8.0.0a0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI python-keystoneclient: affected < 0.4.0; fixed in 0.4.0 - PyPI neutron: affected < 7.0.0a0; fixed in 7.0.0a0 - PyPI cinder: affected < 7.0.0a0; fixed in 7.0.0a0 - PyPI keystone: affected < 8.0.0a0; fixed in 8.0.0a0 ## Suggested inspection (read-only) - `python -m pip show python-keystoneclient`: prints the installed version. Run with the environment that serves production active. - `python -m pip show neutron`: prints the installed version. Run with the environment that serves production active. - `python -m pip show cinder`: prints the installed version. Run with the environment that serves production active. - `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on python-keystoneclient, neutron, cinder, keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-qh2x-hpf9-cf2g (OSV record GHSA-qh2x-hpf9-cf2g lists affected ranges: PyPI python-keystoneclient >=0 =0 =0 =0 <8.0.0a0 (fixed)) - Verified: https://github.com/advisories/GHSA-qh2x-hpf9-cf2g (GitHub-reviewed advisory GHSA-qh2x-hpf9-cf2g lists affected ranges: PyPI python-keystoneclient >=0 =0 =0 =0 <8.0.0a0) Commands are suggestions: review each one before running it.
Loading voting…