Skip to content

← Actionable
Unratedamended

OpenStack Cinder Denial of Service using XML entities

CVE-2013-4202GHSA-mfg4-9xf4-f45q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cinder 7.0.0a0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI cinder

    Affected
    < 7.0.0a0
    Fixed in
    7.0.0a0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-4202: 2.63% estimated exploitation activity in the next 30 days; percentile 85.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The (1) backup (api/contrib/backups.py) and (2) volume transfer (contrib/volumetransfer.py) APIs in OpenStack Cinder Grizzly 2013.1.3 and earlier allows remote attackers to cause a denial of service (resource consumption and crash) via an XML Entity Expansion (XEE) attack. NOTE: this issue is due to an incomplete fix for CVE-2013-1664.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mfg4-9xf4-f45q

  2. Revision 1 · created ·

    Published from osv record GHSA-mfg4-9xf4-f45q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4202

Advisory: OpenStack Cinder Denial of Service using XML entities
IDs: CVE-2013-4202, GHSA-mfg4-9xf4-f45q
Record: https://patchnext.com/advisories/cve-2013-4202 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cinder 7.0.0a0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI cinder: affected < 7.0.0a0; fixed in 7.0.0a0

## Suggested inspection (read-only)
- `python -m pip show cinder`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cinder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mfg4-9xf4-f45q (OSV record GHSA-mfg4-9xf4-f45q lists affected ranges: PyPI cinder >=0 <7.0.0a0 (fixed))
- Verified: https://github.com/advisories/GHSA-mfg4-9xf4-f45q (GitHub-reviewed advisory GHSA-mfg4-9xf4-f45q lists affected ranges: PyPI cinder >=0 <7.0.0a0)

Commands are suggestions: review each one before running it.

Loading voting…