Skip to content

← Public intelligence

RubyGems package

ember-source

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1RubyGemsPublished

    Ember.js Potential XSS Exploit When Binding tagName to User-Supplied Data

    CVE-2013-4170 · GHSA-5m48-c37x-f792

    Affected
    • RubyGems ember-source <= 1.0.0.rc1.0; >= 1.0.0.rc2.0, <= 1.0.0.rc2.0; >= 1.0.0.rc3.0, <= 1.0.0.rc3.0; >= 1.0.0.rc4.0, <= 1.0.0.rc4.0; >= 1.0.0.rc5.0, <= 1.0.0.rc5.0; >= 1.0.0.rc6.0, <= 1.0.0.rc6.0
    Fixed in
    1.0.0.rc5.11.0.0.rc4.11.0.0.rc6.11.0.0.rc1.11.0.0.rc3.11.0.0.rc2.1· Vendor fix available
    Issue
    In general, Ember.js escapes or strips any user-supplied content before inserting it in strings that will be sent to innerHTML. However, the tagName property of an Ember.View was inserted into such a string without being sanitized. This means that if an application assigns a view's tagName to user-supplied data, a specially-crafted payload could execute arbitrary JavaScript in the context of the current domain ("XSS"). This vulnerability only affects applications that assign or bind user-provided content to tagName.

    Recommended action: Upgrade to 1.0.0.rc6.1, 1.0.0.rc5.1, 1.0.0.rc4.1 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 5.4RubyGemsPublished

    Ember.js Cross-site Scripting vulnerability

    CVE-2014-0013 · GHSA-8xm3-gm7c-5fjx

    Affected
    • RubyGems ember-source >= 1.0.0.pre4.0, < 1.0.1; >= 1.1.0, < 1.1.3; >= 1.2.0.beta.1, < 1.2.1; >= 1.3.0.beta.1, < 1.3.1; >= 1.4.0-beta.1, <= 1.4.0-beta.1
    Fixed in
    1.3.11.4.0-beta.21.1.31.0.11.2.1· Vendor fix available
    Issue
    Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the {{this}} special Handlebars variable.

    Recommended action: Upgrade to 1.4.0-beta.2 (pre-release), 1.3.1, 1.2.1 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.4RubyGemsPublished

    ember-source Cross-site Scripting vulnerability

    CVE-2014-0014 · GHSA-rcx6-7jp6-pqf2

    Affected
    • RubyGems ember-source >= 1.0.0.pre4.0, < 1.0.1; >= 1.1.0, < 1.1.3; >= 1.2.0.beta.1, < 1.2.1; >= 1.3.0.beta.1, < 1.3.1; >= 1.4.0-beta.1, <= 1.4.0-beta.1
    Fixed in
    1.3.11.4.0-beta.21.1.31.0.11.2.1· Vendor fix available
    Issue
    Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application using the {{group}} Helper and a crafted payload.

    Recommended action: Upgrade to 1.4.0-beta.2 (pre-release), 1.3.1, 1.2.1 or 2 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1RubyGemsPublished

    ember-source vulnerable to Cross-site Scripting

    CVE-2015-1866 · GHSA-mp78-r56v-45qc

    Affected
    • RubyGems ember-source >= 1.10.0, <= 1.10.0; >= 1.11.0, < 1.11.2
    Fixed in
    1.10.11.11.2· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.

    Recommended action: Upgrade to 1.11.2 or 1.10.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. UnratedRubyGemsPublished

    ember-source Cross-site Scripting vulnerability

    CVE-2014-0046 · GHSA-4q53-fqhc-cr46

    Affected
    • RubyGems ember-source >= 1.2.0, < 1.2.2; >= 1.3.0, < 1.3.2; >= 1.4.0.beta.1, < 1.4.0.beta.6
    Fixed in
    1.2.21.4.0.beta.61.3.2· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.

    Recommended action: Upgrade to 1.4.0.beta.6, 1.3.2 or 1.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 6.1RubyGemsPublished

    ember-source Cross-site Scripting vulnerability

    CVE-2015-7565 · GHSA-m3q7-rj8g-m457

    Affected
    • RubyGems ember-source >= 1.8.0, < 1.11.4; >= 1.12.0, < 1.12.2; >= 1.13.0, < 1.13.12; >= 2.0.0, < 2.0.3; >= 2.1.0, < 2.1.2; >= 2.2.0, <= 2.2.0
    Fixed in
    2.0.31.12.22.1.21.13.121.11.42.2.1· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before 1.13.12, 2.0.x before 2.0.3, 2.1.x before 2.1.2, and 2.2.x before 2.2.1 allows remote attackers to inject arbitrary web script or HTML.

    Recommended action: Upgrade to 2.2.1, 2.1.2, 2.0.3 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →