Skip to content

← Actionable
Medium, CVSS 6.1

ember-source vulnerable to Cross-site Scripting

CVE-2015-1866GHSA-mp78-r56v-45qc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ember-source 1.11.2, 1.10.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems ember-source

    Affected
    >= 1.10.0, <= 1.10.0>= 1.11.0, < 1.11.2
    Fixed in
    1.10.1, 1.11.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2015-1866: 1.12% estimated exploitation activity in the next 30 days; percentile 66.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mp78-r56v-45qc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2015-1866

Advisory: ember-source vulnerable to Cross-site Scripting
IDs: CVE-2015-1866, GHSA-mp78-r56v-45qc
Record: https://patchnext.com/advisories/cve-2015-1866 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ember-source 1.11.2, 1.10.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems ember-source: affected >= 1.10.0, <= 1.10.0; >= 1.11.0, < 1.11.2; fixed in 1.10.1, 1.11.2

## Suggested inspection (read-only)
- RubyGems ember-source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ember-source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mp78-r56v-45qc (GitHub-reviewed advisory GHSA-mp78-r56v-45qc lists affected ranges: RubyGems ember-source >=1.10.0 =1.11.0 <1.11.2)

Commands are suggestions: review each one before running it.

Loading voting…