Skip to content

← Actionable
Medium, CVSS 6.1

Ember.js Potential XSS Exploit When Binding tagName to User-Supplied Data

CVE-2013-4170GHSA-5m48-c37x-f792

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ember-source 1.0.0.rc6.1, 1.0.0.rc5.1, 1.0.0.rc4.1, 1.0.0.rc3.1, 1.0.0.rc2.1, 1.0.0.rc1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems ember-source

    Affected
    <= 1.0.0.rc1.0>= 1.0.0.rc2.0, <= 1.0.0.rc2.0>= 1.0.0.rc3.0, <= 1.0.0.rc3.0>= 1.0.0.rc4.0, <= 1.0.0.rc4.0>= 1.0.0.rc5.0, <= 1.0.0.rc5.0>= 1.0.0.rc6.0, <= 1.0.0.rc6.0
    Fixed in
    1.0.0.rc5.1, 1.0.0.rc4.1, 1.0.0.rc6.1, 1.0.0.rc1.1, 1.0.0.rc3.1, 1.0.0.rc2.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5m48-c37x-f792 lists affected ranges: RubyGems ember-source >=0 =1.0.0.rc2.0 =1.0.0.rc3.0 =1.0.0.rc4.0 =1.0.0.rc5.0 =1.0.0.rc6.0 <=1.0.0.rc6.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2013-4170: 0.94% estimated exploitation activity in the next 30 days; percentile 61.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In general, Ember.js escapes or strips any user-supplied content before inserting it in strings that will be sent to innerHTML. However, the tagName property of an Ember.View was inserted into such a string without being sanitized. This means that if an application assigns a view's tagName to user-supplied data, a specially-crafted payload could execute arbitrary JavaScript in the context of the current domain ("XSS"). This vulnerability only affects applications that assign or bind user-provided content to tagName.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5m48-c37x-f792

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4170

Advisory: Ember.js Potential XSS Exploit When Binding `tagName` to User-Supplied Data
IDs: CVE-2013-4170, GHSA-5m48-c37x-f792
Record: https://patchnext.com/advisories/cve-2013-4170 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ember-source 1.0.0.rc6.1, 1.0.0.rc5.1, 1.0.0.rc4.1, 1.0.0.rc3.1, 1.0.0.rc2.1, 1.0.0.rc1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems ember-source: affected <= 1.0.0.rc1.0; >= 1.0.0.rc2.0, <= 1.0.0.rc2.0; >= 1.0.0.rc3.0, <= 1.0.0.rc3.0; >= 1.0.0.rc4.0, <= 1.0.0.rc4.0; >= 1.0.0.rc5.0, <= 1.0.0.rc5.0; >= 1.0.0.rc6.0, <= 1.0.0.rc6.0; fixed in 1.0.0.rc5.1, 1.0.0.rc4.1, 1.0.0.rc6.1, 1.0.0.rc1.1, 1.0.0.rc3.1, 1.0.0.rc2.1

## Suggested inspection (read-only)
- RubyGems ember-source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ember-source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5m48-c37x-f792 (GitHub-reviewed advisory GHSA-5m48-c37x-f792 lists affected ranges: RubyGems ember-source >=0 =1.0.0.rc2.0 =1.0.0.rc3.0 =1.0.0.rc4.0 =1.0.0.rc5.0 =1.0.0.rc6.0 <=1.0.0.rc6.0)

Commands are suggestions: review each one before running it.

Loading voting…