Skip to content

← Actionable
Medium, CVSS 5.4

Ember.js Cross-site Scripting vulnerability

CVE-2014-0013GHSA-8xm3-gm7c-5fjx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ember-source 1.4.0-beta.2, 1.3.1, 1.2.1, 1.1.3, 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems ember-source

    Affected
    >= 1.0.0.pre4.0, < 1.0.1>= 1.1.0, < 1.1.3>= 1.2.0.beta.1, < 1.2.1>= 1.3.0.beta.1, < 1.3.1>= 1.4.0-beta.1, <= 1.4.0-beta.1
    Fixed in
    1.3.1, 1.4.0-beta.2, 1.1.3, 1.0.1, 1.2.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-8xm3-gm7c-5fjx lists affected ranges: RubyGems ember-source >=1.0.0.pre4.0 =1.1.0 =1.2.0.beta.1 =1.3.0.beta.1 =1.4.0-beta.1 <=1.4.0-beta.1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2014-0013: 0.67% estimated exploitation activity in the next 30 days; percentile 52.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging an application that contains templates whose context is set to a user-supplied primitive value and also contain the {{this}} special Handlebars variable.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8xm3-gm7c-5fjx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2014-0013

Advisory: Ember.js Cross-site Scripting vulnerability
IDs: CVE-2014-0013, GHSA-8xm3-gm7c-5fjx
Record: https://patchnext.com/advisories/cve-2014-0013 (revision 1, source checked 26 Oct 2026, 15:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ember-source 1.4.0-beta.2, 1.3.1, 1.2.1, 1.1.3, 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems ember-source: affected >= 1.0.0.pre4.0, < 1.0.1; >= 1.1.0, < 1.1.3; >= 1.2.0.beta.1, < 1.2.1; >= 1.3.0.beta.1, < 1.3.1; >= 1.4.0-beta.1, <= 1.4.0-beta.1; fixed in 1.3.1, 1.4.0-beta.2, 1.1.3, 1.0.1, 1.2.1

## Suggested inspection (read-only)
- RubyGems ember-source: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ember-source.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8xm3-gm7c-5fjx (GitHub-reviewed advisory GHSA-8xm3-gm7c-5fjx lists affected ranges: RubyGems ember-source >=1.0.0.pre4.0 =1.1.0 =1.2.0.beta.1 =1.3.0.beta.1 =1.4.0-beta.1 <=1.4.0-beta.1)

Commands are suggestions: review each one before running it.

Loading voting…