ember-source Cross-site Scripting vulnerability
CVE-2014-0046GHSA-4q53-fqhc-cr46
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ember-source 1.4.0.beta.6, 1.3.2, 1.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems ember-source
- Affected
- >= 1.2.0, < 1.2.2>= 1.3.0, < 1.3.2>= 1.4.0.beta.1, < 1.4.0.beta.6
- Fixed in
- 1.2.2, 1.4.0.beta.6, 1.3.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4q53-fqhc-cr46 lists affected ranges: RubyGems ember-source >=1.2.0 =1.3.0 =1.4.0.beta.1 <1.4.0.beta.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2014-0046: 1.50% estimated exploitation activity in the next 30 days; percentile 74.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before 1.4.0-beta.6, when used in non-block form, allows remote attackers to inject arbitrary web script or HTML via the title attribute.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4q53-fqhc-cr46
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2014-0046 Advisory: ember-source Cross-site Scripting vulnerability IDs: CVE-2014-0046, GHSA-4q53-fqhc-cr46 Record: https://patchnext.com/advisories/cve-2014-0046 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ember-source 1.4.0.beta.6, 1.3.2, 1.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems ember-source: affected >= 1.2.0, < 1.2.2; >= 1.3.0, < 1.3.2; >= 1.4.0.beta.1, < 1.4.0.beta.6; fixed in 1.2.2, 1.4.0.beta.6, 1.3.2 ## Suggested inspection (read-only) - RubyGems ember-source: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ember-source. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4q53-fqhc-cr46 (GitHub-reviewed advisory GHSA-4q53-fqhc-cr46 lists affected ranges: RubyGems ember-source >=1.2.0 =1.3.0 =1.4.0.beta.1 <1.4.0.beta.6) Commands are suggestions: review each one before running it.
Loading voting…