Skip to content

← Public intelligence

RubyGems package

bootstrap-sass

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1RubyGemsAmendedPublished

    Bootstrap vulnerable to Cross-Site Scripting (XSS)

    CVE-2018-14040 · GHSA-3wqf-4x89-9g79

    Affected
    • RubyGems bootstrap-sass >= 2.3.0, < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap starting in version 2.3.0 and prior to 3.4.0, as well as 4.x before 4.1.2, XSS is possible in the collapse data-parent attribute.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8RubyGemsPublished

    Bootstrap-sass contains code execution backdoor

    CVE-2019-10842 · GHSA-vqqv-v9m2-48p2

    Affected
    • RubyGems bootstrap-sass >= 3.2.0.3, <= 3.2.0.3
    Fixed in
    3.2.0.4· Vendor fix available
    Issue
    Arbitrary code execution (via backdoor code) was discovered in bootstrap-sass 3.2.0.3, when downloaded from rubygems.org. An unauthenticated attacker can craft the cfduid cookie value with base64 arbitrary code to be executed via eval(), which can be leveraged to execute arbitrary code on the target system. Note that there are three underscore characters in the cookie name. This is unrelated to the cfduid cookie that is legitimately used by Cloudflare.

    Recommended action: Upgrade to 3.2.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1RubyGemsAmendedPublished

    Bootstrap Vulnerable to Cross-Site Scripting

    CVE-2019-8331 · GHSA-9v3m-8fp8-mj99

    Affected
    • RubyGems bootstrap-sass >= 3.0.0, < 3.4.1
    Fixed in
    3.4.1· Vendor fix available
    Issue
    Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. Recommendation For bootstrap 4.x upgrade to 4.3.1 or later. For bootstrap 3.x upgrade to 3.4.1 or later.

    Recommended action: Upgrade to 3.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.1RubyGemsAmendedPublished

    bootstrap Cross-site Scripting vulnerability

    CVE-2018-20677 · GHSA-ph58-4vrj-w6hr

    Affected
    • RubyGems bootstrap-sass < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap before 3.4.0, XSS is possible in the affix configuration target property.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.1RubyGemsAmendedPublished

    XSS vulnerability that affects bootstrap

    CVE-2018-20676 · GHSA-3mgp-fx93-9xv5

    Affected
    • RubyGems bootstrap-sass < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.1RubyGemsAmendedPublished

    Bootstrap Cross-site Scripting vulnerability

    CVE-2016-10735 · GHSA-4p24-vmcr-4gqj

    Affected
    • RubyGems bootstrap-sass >= 2.0.4, < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap 2.x from 2.0.4, 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute. Note that this is a different vulnerability than CVE-2018-14041. See https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/ for more info.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. Medium, CVSS 6.1RubyGemsAmendedPublished

    Bootstrap Cross-site Scripting vulnerability

    CVE-2018-14042 · GHSA-7mvr-5x2g-wfc8

    Affected
    • RubyGems bootstrap-sass >= 2.3.0, < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap starting in version 2.3.0 and prior to versions 3.4.0 and 4.1.2, XSS is possible in the data-container property of tooltip. This is similar to CVE-2018-14041.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →