Bootstrap-sass contains code execution backdoor
CVE-2019-10842GHSA-vqqv-v9m2-48p2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bootstrap-sass 3.2.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems bootstrap-sass
- Affected
- >= 3.2.0.3, <= 3.2.0.3
- Fixed in
- 3.2.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vqqv-v9m2-48p2 lists affected ranges: RubyGems bootstrap-sass >=3.2.0.3 <=3.2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2019-10842: 4.92% estimated exploitation activity in the next 30 days; percentile 92.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Arbitrary code execution (via backdoor code) was discovered in bootstrap-sass 3.2.0.3, when downloaded from rubygems.org. An unauthenticated attacker can craft the cfduid cookie value with base64 arbitrary code to be executed via eval(), which can be leveraged to execute arbitrary code on the target system. Note that there are three underscore characters in the cookie name. This is unrelated to the cfduid cookie that is legitimately used by Cloudflare.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vqqv-v9m2-48p2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2019-10842 Advisory: Bootstrap-sass contains code execution backdoor IDs: CVE-2019-10842, GHSA-vqqv-v9m2-48p2 Record: https://patchnext.com/advisories/cve-2019-10842 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bootstrap-sass 3.2.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems bootstrap-sass: affected >= 3.2.0.3, <= 3.2.0.3; fixed in 3.2.0.4 ## Suggested inspection (read-only) - RubyGems bootstrap-sass: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bootstrap-sass. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vqqv-v9m2-48p2 (GitHub-reviewed advisory GHSA-vqqv-v9m2-48p2 lists affected ranges: RubyGems bootstrap-sass >=3.2.0.3 <=3.2.0.3) Commands are suggestions: review each one before running it.
Loading voting…