Skip to content

← Actionable
Medium, CVSS 6.1amended

Bootstrap Vulnerable to Cross-Site Scripting

CVE-2019-8331GHSA-9v3m-8fp8-mj99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bootstrap.sass 4.3.1; twitter-bootstrap-rails 5.3.0; org.webjars:bootstrap 4.3.1, 3.4.1; bootstrap-sass 3.4.1; bootstrap.less 3.4.1; 5 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-8331: 16.40% estimated exploitation activity in the next 30 days; percentile 96.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. Recommendation For bootstrap 4.x upgrade to 4.3.1 or later. For bootstrap 3.x upgrade to 3.4.1 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9v3m-8fp8-mj99

  2. Revision 1 · created ·

    Published from osv record GHSA-9v3m-8fp8-mj99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-8331

Advisory: Bootstrap Vulnerable to Cross-Site Scripting
IDs: CVE-2019-8331, GHSA-9v3m-8fp8-mj99
Record: https://patchnext.com/advisories/cve-2019-8331 (revision 2, source checked 26 Oct 2026, 12:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bootstrap.sass 4.3.1; twitter-bootstrap-rails 5.3.0; org.webjars:bootstrap 4.3.1, 3.4.1; bootstrap-sass 3.4.1; bootstrap.less 3.4.1; bootstrap 4.3.1, 3.4.1; bootstrap-sass 3.4.1; bootstrap 4.3.1, 3.4.1; twbs/bootstrap 4.3.1, 3.4.1; bootstrap 4.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet bootstrap.sass: affected < 4.3.1; fixed in 4.3.1
- RubyGems twitter-bootstrap-rails: affected < 5.3.0; fixed in 5.3.0
- Maven org.webjars:bootstrap: affected >= 3.0.0, < 3.4.1; >= 4.0.0, < 4.3.1; fixed in 4.3.1, 3.4.1
- RubyGems bootstrap-sass: affected >= 3.0.0, < 3.4.1; fixed in 3.4.1
- NuGet bootstrap.less: affected >= 3.0.0, < 3.4.1; fixed in 3.4.1
- npm bootstrap: affected >= 4.0.0, < 4.3.1; >= 3.0.0, < 3.4.1; fixed in 4.3.1, 3.4.1
- npm bootstrap-sass: affected >= 3.0.0, < 3.4.1; fixed in 3.4.1
- NuGet bootstrap: affected >= 4.0.0, < 4.3.1; >= 3.0.0, < 3.4.1; fixed in 4.3.1, 3.4.1
- Packagist twbs/bootstrap: affected >= 3.0.0, < 3.4.1; >= 4.0.0, < 4.3.1; fixed in 4.3.1, 3.4.1
- RubyGems bootstrap: affected < 4.3.1; fixed in 4.3.1

## Suggested inspection (read-only)
- NuGet bootstrap.sass: check the installed version with your package manager.
- RubyGems twitter-bootstrap-rails: check the installed version with your package manager.
- Maven org.webjars:bootstrap: check the installed version with your package manager.
- RubyGems bootstrap-sass: check the installed version with your package manager.
- NuGet bootstrap.less: check the installed version with your package manager.
- `npm ls bootstrap --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls bootstrap-sass --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- NuGet bootstrap: check the installed version with your package manager.
- Packagist twbs/bootstrap: check the installed version with your package manager.
- RubyGems bootstrap: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bootstrap.sass, twitter-bootstrap-rails, org.webjars:bootstrap, bootstrap-sass, bootstrap.less, bootstrap, twbs/bootstrap.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9v3m-8fp8-mj99 (OSV record GHSA-9v3m-8fp8-mj99 lists affected ranges: RubyGems bootstrap >=0 =3.0.0 =3.0.0 =4.0.0 =3.0.0 =0 =4.0.0 =3.0.0 =3.0.0 =0 =3.0.0 <3.4.1…)
- Verified: https://github.com/advisories/GHSA-9v3m-8fp8-mj99 (GitHub-reviewed advisory GHSA-9v3m-8fp8-mj99 lists affected ranges: RubyGems bootstrap >=0 =3.0.0 =3.0.0 =4.0.0 =3.0.0 =0 =4.0.0 =3.0.0 =3.0.0 =3.0.0 =4.0.0 =3.0.0 =4.0.0 =0 <5.3.0)

Commands are suggestions: review each one before running it.

Loading voting…