Skip to content

← Public intelligence

npm package

bootstrap

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

7 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.1npmAmendedPublished

    Bootstrap vulnerable to Cross-Site Scripting (XSS)

    CVE-2018-14040 · GHSA-3wqf-4x89-9g79

    Affected
    • npm bootstrap >= 4.0.0, < 4.1.2; >= 2.3.0, < 3.4.0
    Fixed in
    3.4.04.1.2· Vendor fix available
    Issue
    In Bootstrap starting in version 2.3.0 and prior to 3.4.0, as well as 4.x before 4.1.2, XSS is possible in the collapse data-parent attribute.

    Recommended action: Upgrade to 4.1.2 or 3.4.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    Bootstrap Vulnerable to Cross-Site Scripting

    CVE-2019-8331 · GHSA-9v3m-8fp8-mj99

    Affected
    • npm bootstrap >= 4.0.0, < 4.3.1; >= 3.0.0, < 3.4.1
    Fixed in
    4.3.13.4.1· Vendor fix available
    Issue
    Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. Recommendation For bootstrap 4.x upgrade to 4.3.1 or later. For bootstrap 3.x upgrade to 3.4.1 or later.

    Recommended action: Upgrade to 4.3.1 or 3.4.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    bootstrap Cross-site Scripting vulnerability

    CVE-2018-20677 · GHSA-ph58-4vrj-w6hr

    Affected
    • npm bootstrap < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap before 3.4.0, XSS is possible in the affix configuration target property.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Medium, CVSS 6.1npmAmendedPublished

    XSS vulnerability that affects bootstrap

    CVE-2018-20676 · GHSA-3mgp-fx93-9xv5

    Affected
    • npm bootstrap < 3.4.0
    Fixed in
    3.4.0· Vendor fix available
    Issue
    In Bootstrap before 3.4.0, XSS is possible in the tooltip data-viewport attribute.

    Recommended action: Upgrade to 3.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 6.1npmAmendedPublished

    Bootstrap Cross-site Scripting vulnerability

    CVE-2016-10735 · GHSA-4p24-vmcr-4gqj

    Affected
    • npm bootstrap >= 4.0.0-beta, < 4.0.0-beta.2; >= 2.0.4, < 3.4.0
    Fixed in
    4.0.0-beta.23.4.0· Vendor fix available
    Issue
    In Bootstrap 2.x from 2.0.4, 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute. Note that this is a different vulnerability than CVE-2018-14041. See https://blog.getbootstrap.com/2018/12/13/bootstrap-3-4-0/ for more info.

    Recommended action: Upgrade to 4.0.0-beta.2 (pre-release) or 3.4.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. Medium, CVSS 6.1npmAmendedPublished

    Bootstrap Cross-site Scripting vulnerability

    CVE-2018-14042 · GHSA-7mvr-5x2g-wfc8

    Affected
    • npm bootstrap >= 4.0.0, < 4.1.2; >= 2.3.0, < 3.4.0
    Fixed in
    3.4.04.1.2· Vendor fix available
    Issue
    In Bootstrap starting in version 2.3.0 and prior to versions 3.4.0 and 4.1.2, XSS is possible in the data-container property of tooltip. This is similar to CVE-2018-14041.

    Recommended action: Upgrade to 4.1.2 or 3.4.0 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  7. Medium, CVSS 6.1npmAmendedPublished

    Bootstrap Cross-site Scripting vulnerability

    CVE-2018-14041 · GHSA-pj7m-g53m-7638

    Affected
    • npm bootstrap >= 4.0.0, < 4.1.2
    Fixed in
    4.1.2· Vendor fix available
    Issue
    In Bootstrap 4.x before 4.1.2, XSS is possible in the data-target property of scrollspy. This is similar to CVE-2018-14042.

    Recommended action: Upgrade to 4.1.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →