Bootstrap Cross-site Scripting vulnerability
CVE-2018-14041GHSA-pj7m-g53m-7638
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bootstrap.sass 4.1.2; org.webjars:bootstrap 4.1.2; bootstrap 4.1.2; bootstrap 4.1.2; twbs/bootstrap 4.1.2; 3 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet bootstrap.sass
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
Maven org.webjars:bootstrap
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
npm bootstrap
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
NuGet bootstrap
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
Packagist twbs/bootstrap
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
Packagist typo3/cms-core
- Affected
- >= 8.0.0, < 8.7.23>= 9.0.0, < 9.5.4
- Fixed in
- 8.7.23, 9.5.4
Packagist typo3/cms
- Affected
- >= 8.0.0, < 8.7.23>= 9.0.0, < 9.5.4
- Fixed in
- 8.7.23, 9.5.4
RubyGems bootstrap
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pj7m-g53m-7638 lists affected ranges: npm bootstrap >=4.0.0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <4.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pj7m-g53m-7638 lists affected ranges: npm bootstrap >=4.0.0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-14041: 4.31% estimated exploitation activity in the next 30 days; percentile 91.17 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Bootstrap 4.x before 4.1.2, XSS is possible in the data-target property of scrollspy. This is similar to CVE-2018-14042.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pj7m-g53m-7638
- Revision 1 · created ·
Published from osv record GHSA-pj7m-g53m-7638
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-14041 Advisory: Bootstrap Cross-site Scripting vulnerability IDs: CVE-2018-14041, GHSA-pj7m-g53m-7638 Record: https://patchnext.com/advisories/cve-2018-14041 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bootstrap.sass 4.1.2; org.webjars:bootstrap 4.1.2; bootstrap 4.1.2; bootstrap 4.1.2; twbs/bootstrap 4.1.2; typo3/cms-core 9.5.4, 8.7.23; typo3/cms 9.5.4, 8.7.23; bootstrap 4.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet bootstrap.sass: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 - Maven org.webjars:bootstrap: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 - npm bootstrap: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 - NuGet bootstrap: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 - Packagist twbs/bootstrap: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 - Packagist typo3/cms-core: affected >= 8.0.0, < 8.7.23; >= 9.0.0, < 9.5.4; fixed in 8.7.23, 9.5.4 - Packagist typo3/cms: affected >= 8.0.0, < 8.7.23; >= 9.0.0, < 9.5.4; fixed in 8.7.23, 9.5.4 - RubyGems bootstrap: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 ## Suggested inspection (read-only) - NuGet bootstrap.sass: check the installed version with your package manager. - Maven org.webjars:bootstrap: check the installed version with your package manager. - `npm ls bootstrap --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - NuGet bootstrap: check the installed version with your package manager. - Packagist twbs/bootstrap: check the installed version with your package manager. - Packagist typo3/cms-core: check the installed version with your package manager. - Packagist typo3/cms: check the installed version with your package manager. - RubyGems bootstrap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bootstrap.sass, org.webjars:bootstrap, bootstrap, twbs/bootstrap, typo3/cms-core, typo3/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pj7m-g53m-7638 (OSV record GHSA-pj7m-g53m-7638 lists affected ranges: npm bootstrap >=4.0.0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <4.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pj7m-g53m-7638 (GitHub-reviewed advisory GHSA-pj7m-g53m-7638 lists affected ranges: npm bootstrap >=4.0.0 =8.0.0 =9.0.0 =8.0.0 =9.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <4.1.2) Commands are suggestions: review each one before running it.
Loading voting…