Skip to content

← Actionable
Medium, CVSS 6.1amended

bootstrap Cross-site Scripting vulnerability

CVE-2018-20677GHSA-ph58-4vrj-w6hr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.webjars:bootstrap 3.4.0; bootstrap-sass 3.4.0; bootstrap 3.4.0; bootstrap-sass 3.4.0; bootstrap 3.4.0; 2 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-20677: 3.98% estimated exploitation activity in the next 30 days; percentile 90.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Bootstrap before 3.4.0, XSS is possible in the affix configuration target property.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-ph58-4vrj-w6hr

  2. Revision 1 · created ·

    Published from osv record GHSA-ph58-4vrj-w6hr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-20677

Advisory: bootstrap Cross-site Scripting vulnerability
IDs: CVE-2018-20677, GHSA-ph58-4vrj-w6hr
Record: https://patchnext.com/advisories/cve-2018-20677 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.webjars:bootstrap 3.4.0; bootstrap-sass 3.4.0; bootstrap 3.4.0; bootstrap-sass 3.4.0; bootstrap 3.4.0; twbs/bootstrap 3.4.0; bootstrap 3.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.webjars:bootstrap: affected < 3.4.0; fixed in 3.4.0
- RubyGems bootstrap-sass: affected < 3.4.0; fixed in 3.4.0
- npm bootstrap: affected < 3.4.0; fixed in 3.4.0
- npm bootstrap-sass: affected < 3.4.0; fixed in 3.4.0
- NuGet bootstrap: affected < 3.4.0; fixed in 3.4.0
- Packagist twbs/bootstrap: affected < 3.4.0; fixed in 3.4.0
- RubyGems bootstrap: affected < 3.4.0; fixed in 3.4.0

## Suggested inspection (read-only)
- Maven org.webjars:bootstrap: check the installed version with your package manager.
- RubyGems bootstrap-sass: check the installed version with your package manager.
- `npm ls bootstrap --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls bootstrap-sass --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- NuGet bootstrap: check the installed version with your package manager.
- Packagist twbs/bootstrap: check the installed version with your package manager.
- RubyGems bootstrap: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.webjars:bootstrap, bootstrap-sass, bootstrap, twbs/bootstrap.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-ph58-4vrj-w6hr (OSV record GHSA-ph58-4vrj-w6hr lists affected ranges: npm bootstrap >=0 =0 =0 =0 =0 =0 =0 <3.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-ph58-4vrj-w6hr (GitHub-reviewed advisory GHSA-ph58-4vrj-w6hr lists affected ranges: npm bootstrap >=0 =0 =0 =0 =0 =0 =0 <3.4.0)

Commands are suggestions: review each one before running it.

Loading voting…