Bootstrap vulnerable to Cross-Site Scripting (XSS)
CVE-2018-14040GHSA-3wqf-4x89-9g79
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bootstrap.sass 4.1.2; org.webjars:bootstrap 4.1.2, 3.4.0; bootstrap-sass 3.4.0; bootstrap 4.1.2, 3.4.0; bootstrap 4.1.2, 3.4.0; 2 more packages under Affected packages), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet bootstrap.sass
- Affected
- >= 4.0.0, < 4.1.2
- Fixed in
- 4.1.2
Maven org.webjars:bootstrap
- Affected
- >= 4.0.0, < 4.1.2>= 2.3.0, < 3.4.0
- Fixed in
- 3.4.0, 4.1.2
RubyGems bootstrap-sass
- Affected
- >= 2.3.0, < 3.4.0
- Fixed in
- 3.4.0
npm bootstrap
- Affected
- >= 4.0.0, < 4.1.2>= 2.3.0, < 3.4.0
- Fixed in
- 3.4.0, 4.1.2
NuGet bootstrap
- Affected
- >= 2.3.0, < 3.4.0>= 4.0.0, < 4.1.2
- Fixed in
- 3.4.0, 4.1.2
Packagist twbs/bootstrap
- Affected
- >= 2.3.0, < 3.4.0>= 4.0.0, < 4.1.2
- Fixed in
- 3.4.0, 4.1.2
RubyGems bootstrap
- Affected
- >= 4.0.0, < 4.1.2>= 2.3.0, < 3.4.0
- Fixed in
- 3.4.0, 4.1.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3wqf-4x89-9g79 lists affected ranges: npm bootstrap >=4.0.0 =2.3.0 =4.0.0 =2.3.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 <4.1.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3wqf-4x89-9g79 lists affected ranges: npm bootstrap >=4.0.0 =2.3.0 =4.0.0 =2.3.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 <4.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2018-14040: 4.13% estimated exploitation activity in the next 30 days; percentile 90.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Bootstrap starting in version 2.3.0 and prior to 3.4.0, as well as 4.x before 4.1.2, XSS is possible in the collapse data-parent attribute.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3wqf-4x89-9g79
- Revision 1 · created ·
Published from osv record GHSA-3wqf-4x89-9g79
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2018-14040 Advisory: Bootstrap vulnerable to Cross-Site Scripting (XSS) IDs: CVE-2018-14040, GHSA-3wqf-4x89-9g79 Record: https://patchnext.com/advisories/cve-2018-14040 (revision 2, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bootstrap.sass 4.1.2; org.webjars:bootstrap 4.1.2, 3.4.0; bootstrap-sass 3.4.0; bootstrap 4.1.2, 3.4.0; bootstrap 4.1.2, 3.4.0; twbs/bootstrap 4.1.2, 3.4.0; bootstrap 4.1.2, 3.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet bootstrap.sass: affected >= 4.0.0, < 4.1.2; fixed in 4.1.2 - Maven org.webjars:bootstrap: affected >= 4.0.0, < 4.1.2; >= 2.3.0, < 3.4.0; fixed in 3.4.0, 4.1.2 - RubyGems bootstrap-sass: affected >= 2.3.0, < 3.4.0; fixed in 3.4.0 - npm bootstrap: affected >= 4.0.0, < 4.1.2; >= 2.3.0, < 3.4.0; fixed in 3.4.0, 4.1.2 - NuGet bootstrap: affected >= 2.3.0, < 3.4.0; >= 4.0.0, < 4.1.2; fixed in 3.4.0, 4.1.2 - Packagist twbs/bootstrap: affected >= 2.3.0, < 3.4.0; >= 4.0.0, < 4.1.2; fixed in 3.4.0, 4.1.2 - RubyGems bootstrap: affected >= 4.0.0, < 4.1.2; >= 2.3.0, < 3.4.0; fixed in 3.4.0, 4.1.2 ## Suggested inspection (read-only) - NuGet bootstrap.sass: check the installed version with your package manager. - Maven org.webjars:bootstrap: check the installed version with your package manager. - RubyGems bootstrap-sass: check the installed version with your package manager. - `npm ls bootstrap --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - NuGet bootstrap: check the installed version with your package manager. - Packagist twbs/bootstrap: check the installed version with your package manager. - RubyGems bootstrap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bootstrap.sass, org.webjars:bootstrap, bootstrap-sass, bootstrap, twbs/bootstrap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3wqf-4x89-9g79 (OSV record GHSA-3wqf-4x89-9g79 lists affected ranges: npm bootstrap >=4.0.0 =2.3.0 =4.0.0 =2.3.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 <4.1.2 (fixed)) - Verified: https://github.com/advisories/GHSA-3wqf-4x89-9g79 (GitHub-reviewed advisory GHSA-3wqf-4x89-9g79 lists affected ranges: npm bootstrap >=4.0.0 =2.3.0 =4.0.0 =2.3.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 =4.0.0 =2.3.0 =2.3.0 =4.0.0 <4.1.2) Commands are suggestions: review each one before running it.
Loading voting…