Medium, CVSS 6.1NuGetAmendedPublished
Bootstrap Vulnerable to Cross-Site Scripting
CVE-2019-8331 · GHSA-9v3m-8fp8-mj99
- Affected
- NuGet bootstrap.less >= 3.0.0, < 3.4.1
- Fixed in
- 3.4.1· Vendor fix available
- Issue
- Versions of bootstrap prior to 3.4.1 for 3.x and 4.3.1 for 4.x are vulnerable to Cross-Site Scripting (XSS). The data-template attribute of the tooltip and popover plugins lacks input sanitization and may allow attacker to execute arbitrary JavaScript. Recommendation For bootstrap 4.x upgrade to 4.3.1 or later. For bootstrap 3.x upgrade to 3.4.1 or later.
Recommended action: Upgrade to 3.4.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.