Skip to content

← Public intelligence

Packagist package

drupal/core-recommended

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.5PackagistPublished

    Drupal core contains a potential PHP Object Injection vulnerability

    CVE-2024-55637 · GHSA-w6rx-9g2x-mg5g

    Affected
    • Packagist drupal/core-recommended >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8
    Fixed in
    11.0.810.2.1110.3.9· Vendor fix available
    Issue
    Drupal core contains a potential PHP Object Injection vulnerability that (if combined with another exploit) could lead to Remote Code Execution. It is not directly exploitable. This issue is mitigated by the fact that in order for it to be exploitable, a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize(). There are no such known exploits in Drupal core. To help protect against this potential vulnerability, types have been added to properties in some of Drupal core's classes. If an application extends those classes, the same types may need to be specified on the subclass to avoid a TypeError. This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

    Recommended action: Upgrade to 11.0.8, 10.3.9 or 10.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Low, CVSS 2.3PackagistPublished

    Drupal core contains a potential PHP Object Injection vulnerability

    CVE-2024-55636 · GHSA-938f-5r4f-h65v

    Affected
    • Packagist drupal/core-recommended >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8
    Fixed in
    11.0.810.2.1110.3.9· Vendor fix available
    Issue
    Drupal core contains a potential PHP Object Injection vulnerability that (if combined with another exploit) could lead to Artbitrary File Deletion. It is not directly exploitable. This issue is mitigated by the fact that in order to be exploitable, a separate vulnerability must be present that allows an attacker to pass unsafe input to unserialize(). There are no such known exploits in Drupal core. To help protect against this vulnerability, types have been added to properties in some of Drupal core's classes. If an application extends those classes, the same types may need to be specified on the subclass to avoid a TypeError. This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

    Recommended action: Upgrade to 11.0.8, 10.3.9 or 10.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.9PackagistPublished

    Drupal core Access bypass

    CVE-2024-55634 · GHSA-7cwc-fjqm-8vh8

    Affected
    • Packagist drupal/core-recommended >= 8.0.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8
    Fixed in
    11.0.810.2.1110.3.9· Vendor fix available
    Issue
    Drupal's uniqueness checking for certain user fields is inconsistent depending on the database engine and its collation. As a result, a user may be able to register with the same email address as another user. This may lead to data integrity issues. This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

    Recommended action: Upgrade to 11.0.8, 10.3.9 or 10.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5PackagistPublished

    Drupal core contains a potential PHP Object Injection vulnerability

    CVE-2024-55638 · GHSA-gvf2-2f4g-jqf4

    Affected
    • Packagist drupal/core-recommended >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 7.0, < 7.102
    Fixed in
    7.10210.2.1110.3.9· Vendor fix available
    Issue
    Drupal core contains a potential PHP Object Injection vulnerability that (if combined with another exploit) could lead to Remote Code Execution. It is not directly exploitable. This issue is mitigated by the fact that in order for it to be exploitable, a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize(). There are no such known exploits in Drupal core. To help protect against this potential vulnerability, some additional checks have been added to Drupal core's database code. If you use a third-party database driver, check the release notes for additional configuration steps that may be required in certain cases. This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9.

    Recommended action: Upgrade to 10.3.9, 10.2.11 or 7.102 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Medium, CVSS 5.3PackagistPublished

    Drupal Core Cross-Site Scripting (XSS)

    CVE-2024-12393 · GHSA-8mvq-8h2v-j9vf

    Affected
    • Packagist drupal/core-recommended >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8
    Fixed in
    11.0.810.2.1110.3.9· Vendor fix available
    Issue
    Drupal uses JavaScript to render status messages in some cases and configurations. In certain situations, the status messages are not adequately sanitized. This issue affects Drupal Core: from 8.8.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

    Recommended action: Upgrade to 11.0.8, 10.3.9 or 10.2.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Medium, CVSS 6.3PackagistPublished

    Drupal Full Path Disclosure

    CVE-2024-45440 · GHSA-mg8j-w93w-xjgc

    Affected
    • Packagist drupal/core-recommended >= 11.0.0, < 11.0.5; >= 10.3.0, < 10.3.6; >= 8.0.0, < 10.2.9
    Fixed in
    10.2.910.3.611.0.5· Vendor fix available
    Issue
    core/authorize.php in Drupal 11.x-dev allows Full Path Disclosure (even when error logging is None) if the value of hashsalt is filegetcontents of a file that does not exist.

    Recommended action: Upgrade to 11.0.5, 10.3.6 or 10.2.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →