Skip to content

← Actionable
Medium, CVSS 5.3

Drupal Core Cross-Site Scripting (XSS)

CVE-2024-12393GHSA-8mvq-8h2v-j9vf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.0.8, 10.3.9, 10.2.11; drupal/core-recommended 11.0.8, 10.3.9, 10.2.11; drupal/drupal 11.0.8, 10.3.9, 10.2.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.8.0, < 10.2.11>= 10.3.0, < 10.3.9>= 11.0.0, < 11.0.8
    Fixed in
    11.0.8, 10.2.11, 10.3.9
  • Packagist drupal/core-recommended

    Affected
    >= 8.8.0, < 10.2.11>= 10.3.0, < 10.3.9>= 11.0.0, < 11.0.8
    Fixed in
    11.0.8, 10.2.11, 10.3.9
  • Packagist drupal/drupal

    Affected
    >= 8.8.0, < 10.2.11>= 10.3.0, < 10.3.9>= 11.0.0, < 11.0.8
    Fixed in
    11.0.8, 10.2.11, 10.3.9

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-8mvq-8h2v-j9vf lists affected ranges: Packagist drupal/core >=8.8.0 =10.3.0 =11.0.0 =8.8.0 =10.3.0 =11.0.0 =8.8.0 =10.3.0 =11.0.0 <11.0.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-12393: 0.34% estimated exploitation activity in the next 30 days; percentile 27.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Drupal uses JavaScript to render status messages in some cases and configurations. In certain situations, the status messages are not adequately sanitized. This issue affects Drupal Core: from 8.8.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8mvq-8h2v-j9vf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-12393

Advisory: Drupal Core Cross-Site Scripting (XSS)
IDs: CVE-2024-12393, GHSA-8mvq-8h2v-j9vf
Record: https://patchnext.com/advisories/cve-2024-12393 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.0.8, 10.3.9, 10.2.11; drupal/core-recommended 11.0.8, 10.3.9, 10.2.11; drupal/drupal 11.0.8, 10.3.9, 10.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8; fixed in 11.0.8, 10.2.11, 10.3.9
- Packagist drupal/core-recommended: affected >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8; fixed in 11.0.8, 10.2.11, 10.3.9
- Packagist drupal/drupal: affected >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8; fixed in 11.0.8, 10.2.11, 10.3.9

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/core-recommended: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/core-recommended, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8mvq-8h2v-j9vf (GitHub-reviewed advisory GHSA-8mvq-8h2v-j9vf lists affected ranges: Packagist drupal/core >=8.8.0 =10.3.0 =11.0.0 =8.8.0 =10.3.0 =11.0.0 =8.8.0 =10.3.0 =11.0.0 <11.0.8)

Commands are suggestions: review each one before running it.

Loading voting…