Skip to content

← Actionable
Medium, CVSS 6.9

Drupal core Access bypass

CVE-2024-55634GHSA-7cwc-fjqm-8vh8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.0.8, 10.3.9, 10.2.11; drupal/core-recommended 11.0.8, 10.3.9, 10.2.11; drupal/drupal 11.0.8, 10.3.9, 10.2.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.0.0, < 10.2.11>= 10.3.0, < 10.3.9>= 11.0.0, < 11.0.8
    Fixed in
    11.0.8, 10.2.11, 10.3.9
  • Packagist drupal/core-recommended

    Affected
    >= 8.0.0, < 10.2.11>= 10.3.0, < 10.3.9>= 11.0.0, < 11.0.8
    Fixed in
    11.0.8, 10.2.11, 10.3.9
  • Packagist drupal/drupal

    Affected
    >= 8.0.0, < 10.2.11>= 10.3.0, < 10.3.9>= 11.0.0, < 11.0.8
    Fixed in
    11.0.8, 10.2.11, 10.3.9

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-7cwc-fjqm-8vh8 lists affected ranges: Packagist drupal/core >=8.0.0 =10.3.0 =11.0.0 =8.0.0 =10.3.0 =11.0.0 =8.0.0 =10.3.0 =11.0.0 <11.0.8

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-55634: 0.41% estimated exploitation activity in the next 30 days; percentile 35.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Drupal's uniqueness checking for certain user fields is inconsistent depending on the database engine and its collation. As a result, a user may be able to register with the same email address as another user. This may lead to data integrity issues. This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7cwc-fjqm-8vh8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-55634

Advisory: Drupal core Access bypass
IDs: CVE-2024-55634, GHSA-7cwc-fjqm-8vh8
Record: https://patchnext.com/advisories/cve-2024-55634 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.0.8, 10.3.9, 10.2.11; drupal/core-recommended 11.0.8, 10.3.9, 10.2.11; drupal/drupal 11.0.8, 10.3.9, 10.2.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.0.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8; fixed in 11.0.8, 10.2.11, 10.3.9
- Packagist drupal/core-recommended: affected >= 8.0.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8; fixed in 11.0.8, 10.2.11, 10.3.9
- Packagist drupal/drupal: affected >= 8.0.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 11.0.0, < 11.0.8; fixed in 11.0.8, 10.2.11, 10.3.9

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/core-recommended: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/core-recommended, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7cwc-fjqm-8vh8 (GitHub-reviewed advisory GHSA-7cwc-fjqm-8vh8 lists affected ranges: Packagist drupal/core >=8.0.0 =10.3.0 =11.0.0 =8.0.0 =10.3.0 =11.0.0 =8.0.0 =10.3.0 =11.0.0 <11.0.8)

Commands are suggestions: review each one before running it.

Loading voting…