Skip to content

← Actionable
Medium, CVSS 6.3

Drupal Full Path Disclosure

CVE-2024-45440GHSA-mg8j-w93w-xjgc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 11.0.5, 10.3.6, 10.2.9; drupal/core-recommended 11.0.5, 10.3.6, 10.2.9; drupal/drupal 11.0.5, 10.3.6, 10.2.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 11.0.0, < 11.0.5>= 10.3.0, < 10.3.6>= 8.0.0, < 10.2.9
    Fixed in
    10.2.9, 10.3.6, 11.0.5
  • Packagist drupal/core-recommended

    Affected
    >= 11.0.0, < 11.0.5>= 10.3.0, < 10.3.6>= 8.0.0, < 10.2.9
    Fixed in
    10.2.9, 10.3.6, 11.0.5
  • Packagist drupal/drupal

    Affected
    >= 11.0.0, < 11.0.5>= 10.3.0, < 10.3.6>= 8.0.0, < 10.2.9
    Fixed in
    10.2.9, 10.3.6, 11.0.5

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-mg8j-w93w-xjgc lists affected ranges: Packagist drupal/drupal >=11.0.0 =10.3.0 =8.0.0 =11.0.0 =10.3.0 =8.0.0 =11.0.0 =10.3.0 =8.0.0 <10.2.9

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-45440: 9.27% estimated exploitation activity in the next 30 days; percentile 95.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

core/authorize.php in Drupal 11.x-dev allows Full Path Disclosure (even when error logging is None) if the value of hashsalt is filegetcontents of a file that does not exist.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mg8j-w93w-xjgc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-45440

Advisory: Drupal Full Path Disclosure
IDs: CVE-2024-45440, GHSA-mg8j-w93w-xjgc
Record: https://patchnext.com/advisories/cve-2024-45440 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 11.0.5, 10.3.6, 10.2.9; drupal/core-recommended 11.0.5, 10.3.6, 10.2.9; drupal/drupal 11.0.5, 10.3.6, 10.2.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 11.0.0, < 11.0.5; >= 10.3.0, < 10.3.6; >= 8.0.0, < 10.2.9; fixed in 10.2.9, 10.3.6, 11.0.5
- Packagist drupal/core-recommended: affected >= 11.0.0, < 11.0.5; >= 10.3.0, < 10.3.6; >= 8.0.0, < 10.2.9; fixed in 10.2.9, 10.3.6, 11.0.5
- Packagist drupal/drupal: affected >= 11.0.0, < 11.0.5; >= 10.3.0, < 10.3.6; >= 8.0.0, < 10.2.9; fixed in 10.2.9, 10.3.6, 11.0.5

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/core-recommended: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/core-recommended, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mg8j-w93w-xjgc (GitHub-reviewed advisory GHSA-mg8j-w93w-xjgc lists affected ranges: Packagist drupal/drupal >=11.0.0 =10.3.0 =8.0.0 =11.0.0 =10.3.0 =8.0.0 =11.0.0 =10.3.0 =8.0.0 <10.2.9)

Commands are suggestions: review each one before running it.

Loading voting…