Skip to content

← Actionable
High, CVSS 7.5

Drupal core contains a potential PHP Object Injection vulnerability

CVE-2024-55638GHSA-gvf2-2f4g-jqf4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 10.3.9, 10.2.11, 7.102; drupal/core-recommended 10.3.9, 10.2.11, 7.102; drupal/drupal 10.3.9, 10.2.11, 7.102), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.8.0, < 10.2.11>= 10.3.0, < 10.3.9>= 7.0, < 7.102
    Fixed in
    7.102, 10.2.11, 10.3.9
  • Packagist drupal/core-recommended

    Affected
    >= 8.8.0, < 10.2.11>= 10.3.0, < 10.3.9>= 7.0, < 7.102
    Fixed in
    7.102, 10.2.11, 10.3.9
  • Packagist drupal/drupal

    Affected
    >= 8.8.0, < 10.2.11>= 10.3.0, < 10.3.9>= 7.0, < 7.102
    Fixed in
    7.102, 10.2.11, 10.3.9

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-gvf2-2f4g-jqf4 lists affected ranges: Packagist drupal/core >=8.8.0 =10.3.0 =7.0 =8.8.0 =10.3.0 =7.0 =8.8.0 =10.3.0 =7.0 <7.102

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.5 · CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-55638: 0.98% estimated exploitation activity in the next 30 days; percentile 62.37 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Drupal core contains a potential PHP Object Injection vulnerability that (if combined with another exploit) could lead to Remote Code Execution. It is not directly exploitable. This issue is mitigated by the fact that in order for it to be exploitable, a separate vulnerability must be present to allow an attacker to pass unsafe input to unserialize(). There are no such known exploits in Drupal core. To help protect against this potential vulnerability, some additional checks have been added to Drupal core's database code. If you use a third-party database driver, check the release notes for additional configuration steps that may be required in certain cases. This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gvf2-2f4g-jqf4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-55638

Advisory: Drupal core contains a potential PHP Object Injection vulnerability
IDs: CVE-2024-55638, GHSA-gvf2-2f4g-jqf4
Record: https://patchnext.com/advisories/cve-2024-55638 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 10.3.9, 10.2.11, 7.102; drupal/core-recommended 10.3.9, 10.2.11, 7.102; drupal/drupal 10.3.9, 10.2.11, 7.102. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 7.0, < 7.102; fixed in 7.102, 10.2.11, 10.3.9
- Packagist drupal/core-recommended: affected >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 7.0, < 7.102; fixed in 7.102, 10.2.11, 10.3.9
- Packagist drupal/drupal: affected >= 8.8.0, < 10.2.11; >= 10.3.0, < 10.3.9; >= 7.0, < 7.102; fixed in 7.102, 10.2.11, 10.3.9

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/core-recommended: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/core-recommended, drupal/drupal.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gvf2-2f4g-jqf4 (GitHub-reviewed advisory GHSA-gvf2-2f4g-jqf4 lists affected ranges: Packagist drupal/core >=8.8.0 =10.3.0 =7.0 =8.8.0 =10.3.0 =7.0 =8.8.0 =10.3.0 =7.0 <7.102)

Commands are suggestions: review each one before running it.

Loading voting…