Skip to content

← Public intelligence

Packagist package

contao/core

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

9 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPackagistPublished

    contao/core PHP object injection vulnerability allows for arbitrary code execution

    GHSA-wq43-8r5p-w3mc

    Affected
    • Packagist contao/core >= 2.0.0, < 2.11.14; >= 3.0.0, < 3.2.5
    Fixed in
    2.11.143.2.5· Vendor fix available
    Issue
    PHP object injection vulnerability was identified in contao/core due to untrusted data being passed to deserialize() function.

    Recommended action: Upgrade to 3.2.5 or 2.11.14 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.0PackagistPublished

    contao/core Insufficient input validation allows for code injection and remote execution

    GHSA-wxxw-5gq6-j2g5

    Affected
    • Packagist contao/core >= 2.0.0, < 2.11.17; >= 3.0.0, < 3.2.9
    Fixed in
    2.11.173.2.9· Vendor fix available
    Issue
    contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.

    Recommended action: Upgrade to 3.2.9 or 2.11.17 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.1PackagistPublished

    Contao Cross-site Scripting vulnerabililty

    CVE-2018-5478 · GHSA-mpg7-2rx9-h5qp

    Affected
    • Packagist contao/core >= 3.0.0, < 3.5.32
    Fixed in
    3.5.32· Vendor fix available
    Issue
    Contao 3.x before 3.5.32 allows Cross-site Scripting (XSS) via the unsubscribe module in the frontend newsletter extension.

    Recommended action: Upgrade to 3.5.32 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.1PackagistAmendedPublished

    MediaElement Vulnerable to Reflected XSS

    CVE-2016-4567 · GHSA-277w-qpxr-2549

    Affected
    • Packagist contao/core >= 3.0.0, < 3.5.15
    Fixed in
    3.5.15· Vendor fix available
    Issue
    Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.swf in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."

    Recommended action: Upgrade to 3.5.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 4.3PackagistPublished

    Contao Core directory traversal vulnerability

    CVE-2015-0269 · GHSA-4r6g-xhx7-fm36

    Affected
    • Packagist contao/core >= 3.4.0, < 3.4.4; >= 2.0.0, < 3.2.19
    Fixed in
    3.4.43.2.19· Vendor fix available
    Issue
    Directory traversal vulnerability in Contao before 3.2.19, and 3.4.x before 3.4.4 allows remote authenticated backend users to view files outside their file mounts or the document root via unspecified vectors.

    Recommended action: Upgrade to 3.4.4 or 3.2.19 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. Critical, CVSS 9.8PackagistPublished

    Contao Does Not Invalidate Existing Sessions When Password Changes

    CVE-2019-10641 · GHSA-vcgg-hp4r-87gx

    Affected
    • Packagist contao/core >= 3.0.0, < 3.5.39
    Fixed in
    3.5.39· Vendor fix available
    Issue
    Security researcher Ali Razzaq has discovered that existing sessions are not correctly invalidated when a user changes their password in the backend or frontend.

    Recommended action: Upgrade to 3.5.39 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  7. High, CVSS 8.8PackagistPublished

    Contao Core directory traversal vulnerability

    CVE-2017-10993 · GHSA-x5g4-crxq-qxjx

    Affected
    • Packagist contao/core >= 3.0.0, < 3.5.28
    Fixed in
    3.5.28· Vendor fix available
    Issue
    A logged in back end user can include arbitrary PHP files by manipulating an URL parameter. Since Contao does not allow to upload PHP files in the file manager, the attack is limited to the existing PHP files on the server.

    Recommended action: Upgrade to 3.5.28 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  8. High, CVSS 8.8PackagistPublished

    Contao core SQL Injection Vulnerability

    CVE-2012-4383 · GHSA-9jq2-jvwc-p52f

    Affected
    • Packagist contao/core < 2.11.4
    Fixed in
    2.11.4· Vendor fix available
    Issue
    Contao core prior to 2.11.4 has a SQL injection vulnerability in contao-2.11.3\system\modules\backend\Ajax.php

    Recommended action: Upgrade to 2.11.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  9. Medium, CVSS 6.1PackagistPublished

    Cross-site Scripting in Contao

    CVE-2018-10125 · GHSA-pj4j-287j-f742

    Affected
    • Packagist contao/core >= 3.0.0, < 3.5.35
    Fixed in
    3.5.35· Vendor fix available
    Issue
    Contao before 4.5.7 has XSS in the system log.

    Recommended action: Upgrade to 3.5.35 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →