Skip to content

← Actionable
Critical, CVSS 9.8

Contao Does Not Invalidate Existing Sessions When Password Changes

CVE-2019-10641GHSA-vcgg-hp4r-87gx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core 3.5.39; contao/contao 4.7.3, 4.4.37; contao/core-bundle 4.7.3, 4.4.37), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/core

    Affected
    >= 3.0.0, < 3.5.39
    Fixed in
    3.5.39
  • Packagist contao/contao

    Affected
    >= 4.0.0, < 4.4.37>= 4.5.0, < 4.7.3
    Fixed in
    4.7.3, 4.4.37
  • Packagist contao/core-bundle

    Affected
    >= 4.0.0, < 4.4.37>= 4.5.0, < 4.7.3
    Fixed in
    4.7.3, 4.4.37

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2019-10641: 1.34% estimated exploitation activity in the next 30 days; percentile 71.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Security researcher Ali Razzaq has discovered that existing sessions are not correctly invalidated when a user changes their password in the backend or frontend.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vcgg-hp4r-87gx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10641

Advisory: Contao Does Not Invalidate Existing Sessions When Password Changes
IDs: CVE-2019-10641, GHSA-vcgg-hp4r-87gx
Record: https://patchnext.com/advisories/cve-2019-10641 (revision 1, source checked 26 Oct 2026, 14:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/core 3.5.39; contao/contao 4.7.3, 4.4.37; contao/core-bundle 4.7.3, 4.4.37. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/core: affected >= 3.0.0, < 3.5.39; fixed in 3.5.39
- Packagist contao/contao: affected >= 4.0.0, < 4.4.37; >= 4.5.0, < 4.7.3; fixed in 4.7.3, 4.4.37
- Packagist contao/core-bundle: affected >= 4.0.0, < 4.4.37; >= 4.5.0, < 4.7.3; fixed in 4.7.3, 4.4.37

## Suggested inspection (read-only)
- Packagist contao/core: check the installed version with your package manager.
- Packagist contao/contao: check the installed version with your package manager.
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/core, contao/contao, contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vcgg-hp4r-87gx (GitHub-reviewed advisory GHSA-vcgg-hp4r-87gx lists affected ranges: Packagist contao/contao >=4.0.0 =4.5.0 =4.0.0 =4.5.0 =3.0.0 <3.5.39)

Commands are suggestions: review each one before running it.

Loading voting…