MediaElement Vulnerable to Reflected XSS
CVE-2016-4567GHSA-277w-qpxr-2549
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core 3.5.15; mediaelement 2.11.1; contao-components/mediaelement 2.21.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/core
- Affected
- >= 3.0.0, < 3.5.15
- Fixed in
- 3.5.15
npm mediaelement
- Affected
- < 2.11.1
- Fixed in
- 2.11.1
Packagist contao-components/mediaelement
- Affected
- >= 2.14.2, < 2.21.1
- Fixed in
- 2.21.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-277w-qpxr-2549 lists affected ranges: npm mediaelement >=0 =2.14.2 =3.0.0 <3.5.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-277w-qpxr-2549 lists affected ranges: npm mediaelement >=0 =2.14.2 =3.0.0 <3.5.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2016-4567: 7.35% estimated exploitation activity in the next 30 days; percentile 94.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.swf in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-277w-qpxr-2549
- Revision 1 · created ·
Published from osv record GHSA-277w-qpxr-2549
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-4567 Advisory: MediaElement Vulnerable to Reflected XSS IDs: CVE-2016-4567, GHSA-277w-qpxr-2549 Record: https://patchnext.com/advisories/cve-2016-4567 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/core 3.5.15; mediaelement 2.11.1; contao-components/mediaelement 2.21.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/core: affected >= 3.0.0, < 3.5.15; fixed in 3.5.15 - npm mediaelement: affected < 2.11.1; fixed in 2.11.1 - Packagist contao-components/mediaelement: affected >= 2.14.2, < 2.21.1; fixed in 2.21.1 ## Suggested inspection (read-only) - Packagist contao/core: check the installed version with your package manager. - `npm ls mediaelement --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Packagist contao-components/mediaelement: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/core, mediaelement, contao-components/mediaelement. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-277w-qpxr-2549 (OSV record GHSA-277w-qpxr-2549 lists affected ranges: npm mediaelement >=0 =2.14.2 =3.0.0 <3.5.15 (fixed)) - Verified: https://github.com/advisories/GHSA-277w-qpxr-2549 (GitHub-reviewed advisory GHSA-277w-qpxr-2549 lists affected ranges: npm mediaelement >=0 =2.14.2 =3.0.0 <3.5.15) Commands are suggestions: review each one before running it.
Loading voting…