Medium, CVSS 6.1PackagistAmendedPublished
MediaElement Vulnerable to Reflected XSS
CVE-2016-4567 · GHSA-277w-qpxr-2549
- Affected
- Packagist contao-components/mediaelement >= 2.14.2, < 2.21.1
- Fixed in
- 2.21.1· Vendor fix available
- Issue
- Cross-site scripting (XSS) vulnerability in flash/FlashMediaElement.swf in MediaElement.js before 2.21.0, as used in WordPress before 4.5.2, allows remote attackers to inject arbitrary web script or HTML via an obfuscated form of the jsinitfunction parameter, as demonstrated by "jsinitfunctio%gn."
Recommended action: Upgrade to 2.21.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.