Contao core SQL Injection Vulnerability
CVE-2012-4383GHSA-9jq2-jvwc-p52f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core 2.11.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/core
- Affected
- < 2.11.4
- Fixed in
- 2.11.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jq2-jvwc-p52f lists affected ranges: Packagist contao/core >=0 <2.11.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2012-4383: 0.92% estimated exploitation activity in the next 30 days; percentile 60.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Contao core prior to 2.11.4 has a SQL injection vulnerability in contao-2.11.3\system\modules\backend\Ajax.php
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9jq2-jvwc-p52f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-4383 Advisory: Contao core SQL Injection Vulnerability IDs: CVE-2012-4383, GHSA-9jq2-jvwc-p52f Record: https://patchnext.com/advisories/cve-2012-4383 (revision 1, source checked 26 Oct 2026, 14:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/core 2.11.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/core: affected < 2.11.4; fixed in 2.11.4 ## Suggested inspection (read-only) - Packagist contao/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9jq2-jvwc-p52f (GitHub-reviewed advisory GHSA-9jq2-jvwc-p52f lists affected ranges: Packagist contao/core >=0 <2.11.4) Commands are suggestions: review each one before running it.
Loading voting…