contao/core Insufficient input validation allows for code injection and remote execution
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/core 3.2.9, 2.11.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist contao/core
- Affected
- >= 2.0.0, < 2.11.17>= 3.0.0, < 3.2.9
- Fixed in
- 2.11.17, 3.2.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wxxw-5gq6-j2g5 lists affected ranges: Packagist contao/core >=2.0.0 =3.0.0 <3.2.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
contao/core versions 2.x prior to 2.11.17 and 3.x prior to 3.2.9 are vulnerable to arbitrary code execution on the server due to insufficient input validation. In fact, attackers can remove or change pathconfig.php by entering a URL, meaning that the entire Contao installation will no longer be accessible or malicious code can be executed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wxxw-5gq6-j2g5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-wxxw-5gq6-j2g5 Advisory: contao/core Insufficient input validation allows for code injection and remote execution IDs: GHSA-wxxw-5gq6-j2g5 Record: https://patchnext.com/advisories/ghsa-wxxw-5gq6-j2g5 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: contao/core 3.2.9, 2.11.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist contao/core: affected >= 2.0.0, < 2.11.17; >= 3.0.0, < 3.2.9; fixed in 2.11.17, 3.2.9 ## Suggested inspection (read-only) - Packagist contao/core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on contao/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wxxw-5gq6-j2g5 (GitHub-reviewed advisory GHSA-wxxw-5gq6-j2g5 lists affected ranges: Packagist contao/core >=2.0.0 =3.0.0 <3.2.9) Commands are suggestions: review each one before running it.
Loading voting…