Skip to content

← Public intelligence

NuGet package

nuget.commandline

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedNuGetPublished

    Defense in Depth update for NuGet Client

    GHSA-g4vj-cjjj-v7hg

    Affected
    • NuGet nuget.commandline >= 4.9.0, <= 4.9.6; >= 5.11.0, <= 5.11.6; >= 6.8.0, <= 6.8.1; >= 6.11.0, <= 6.11.1; >= 6.12.0, <= 6.12.4; >= 6.14.0, <= 6.14.2; >= 7.0.0, <= 7.0.2; >= 7.3.0, <= 7.3.0
    Fixed in
    5.11.76.14.36.11.26.12.57.3.16.8.24.9.77.0.3· Vendor fix available
    Issue
    Impact This update adds validation of the package ID and version during package download, in addition to the existing package signature validation. Patches NuGet The following NuGet.exe, NuGet.CommandLine, NuGet.Packaging, and NuGet.Protocol versions have been patched: |Affected versions|Patched version| |--|--| |= 4.9.0, <= 4.9.6|4.9.7| |= 5.11.0, <= 5.11.6|5.11.7| |= 6.8.0, <= 6.8.1|6.8.2| |= 6.11.0, <= 6.11.1|6.11.2| |= 6.12.0, <= 6.12.4|6.12.5| |= 6.14.0, <= 6.14.2|6.14.3| |= 7.0.0, <= 7.0.2|7.0.3| |7.3.0|7.3.1| .NET SDK .NET 8.0.126 SDK .NET 8.0.420 SDK .NET 9.0.116 SDK .NET 9.0.313 SDK .NET 10.0.106 SDK .NET 10.0.202 SDK Workarounds N/A References https://github.com/NuGet/NuGetGallery/security/advisories/GHSA-9r3h-v4hx-rhfr Credit splitline with DEVCORE

    Recommended action: Upgrade to 7.3.1, 7.0.3, 6.14.3 or 5 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.1NuGetPublished

    NuGet Client Security Feature Bypass Vulnerability

    CVE-2024-0057 · GHSA-68w7-72jg-6qpp

    Affected
    • NuGet nuget.commandline >= 4.6.0, < 5.11.6; >= 6.0.0, < 6.0.6; >= 6.3.0, < 6.3.4; >= 6.4.0, < 6.4.3; >= 6.6.0, < 6.6.2; >= 6.7.0, <= 6.7.0; >= 6.8.0, <= 6.8.0
    Fixed in
    5.11.66.6.26.8.16.3.46.7.16.4.36.0.6· Vendor fix available
    Issue
    Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 7.0 and .NET 8.0. This advisory also provides guidance on what developers can do to update their applications to address this vulnerability. A security feature bypass vulnerability exists when Microsoft .NET Framework-based applications use X.509 chain building APIs but do not completely validate the X.509 certificate due to a logic flaw. An attacker could present an arbitrary untrusted certificate with malformed signatures, triggering a bug in the framework. The framework will correctly report that X.509 chain building failed, but it will return an incorrect reason code for the failure. Applications which utilize this reason code to make their own chain building trust decisions may inadvertently treat this scenario as a successful chain build. This could allow an adversary to subvert the app's typical authentication logic. Affected software NuGet & NuGet Packages…

    Recommended action: Upgrade to 6.8.1, 6.7.1, 6.6.2 or 4 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.8NuGetPublished

    NuGet Elevation of Privilege Vulnerability

    CVE-2022-41032 · GHSA-g3q9-xf95-8hp5

    Affected
    • NuGet nuget.commandline >= 4.6.0, < 4.9.6; >= 5.0.0, < 5.7.3; >= 5.8.0, < 5.9.3; >= 5.10.0, < 5.11.3; >= 6.0.0, < 6.0.3; >= 6.1.0, < 6.2.2; >= 6.3.0, < 6.3.1
    Fixed in
    6.0.34.9.65.7.35.11.36.3.16.2.25.9.3· Vendor fix available
    Issue
    Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 7.0.0-rc, .NET 6.0, .NET Core 3.1, and NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 7.0.0-rc.1, .NET 6.0, .NET Core 3.1, and NuGet clients (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol) where a malicious actor could cause a user to execute arbitrary code. Affected software NuGet & NuGet Packages - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 6.3.0 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 6.2.1 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 6.0.2 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 5.11.2 version or earlier. - Any NuGet.exe,…

    Recommended action: Upgrade to 6.3.1, 6.2.2, 6.0.3 or 4 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 5.5NuGetPublished

    Potential leak of NuGet.org API key

    CVE-2022-30184 · GHSA-3885-8gqc-3wpf

    Affected
    • NuGet nuget.commandline >= 3.5.0, < 4.9.5; >= 5.0.0, < 5.2.1; >= 5.3.0, < 5.7.2; >= 5.8.0, < 5.9.2; >= 5.10.0, < 5.11.2; >= 6.0.0, < 6.0.2; >= 6.1.0, < 6.2.1
    Fixed in
    5.7.25.2.16.2.15.9.24.9.55.11.26.0.2· Vendor fix available
    Issue
    Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET Core 3.1, NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat version range from 3.5.0 to 6.2.0). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET Core 3.1, and NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat version range from 3.5.0 to 6.2.0) where a nuget.org api key could leak due to an incorrect comparison with a server url. Affected software NuGet & NuGet Packages - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 6.2.0 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 6.0.1 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 5.11.1 version or earlier. - Any NuGet.exe,…

    Recommended action: Upgrade to 6.2.1, 6.0.2, 5.11.2 or 4 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →