NuGet Elevation of Privilege Vulnerability
CVE-2022-41032GHSA-g3q9-xf95-8hp5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuget.commands 6.3.1, 6.2.2, 6.0.3, 5.11.3, 5.9.3, 5.7.3, 4.9.6; nuget.commandline 6.3.1, 6.2.2, 6.0.3, 5.11.3, 5.9.3, 5.7.3, 4.9.6; nuget.protocol 6.3.1, 6.2.2, 6.0.3, 5.11.3, 5.9.3, 5.7.3, 4.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet nuget.commands
- Affected
- >= 4.6.0, < 4.9.6>= 5.0.0, < 5.7.3>= 5.8.0, < 5.9.3>= 5.10.0, < 5.11.3>= 6.0.0, < 6.0.3>= 6.1.0, < 6.2.2>= 6.3.0, < 6.3.1
- Fixed in
- 6.0.3, 4.9.6, 5.7.3, 5.11.3, 6.3.1, 6.2.2, 5.9.3
NuGet nuget.commandline
- Affected
- >= 4.6.0, < 4.9.6>= 5.0.0, < 5.7.3>= 5.8.0, < 5.9.3>= 5.10.0, < 5.11.3>= 6.0.0, < 6.0.3>= 6.1.0, < 6.2.2>= 6.3.0, < 6.3.1
- Fixed in
- 6.0.3, 4.9.6, 5.7.3, 5.11.3, 6.3.1, 6.2.2, 5.9.3
NuGet nuget.protocol
- Affected
- >= 4.6.0, < 4.9.6>= 5.0.0, < 5.7.3>= 5.8.0, < 5.9.3>= 5.10.0, < 5.11.3>= 6.0.0, < 6.0.3>= 6.1.0, < 6.2.2>= 6.3.0, < 6.3.1
- Fixed in
- 6.0.3, 4.9.6, 5.7.3, 5.11.3, 6.3.1, 6.2.2, 5.9.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3q9-xf95-8hp5 lists affected ranges: NuGet nuget.commands >=4.6.0 =5.0.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =6.3.0 =4.6.0 =5.0.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =6.3.0 =4.6.0 =5.0.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =6.3.0 <6.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2022-41032: 1.29% estimated exploitation activity in the next 30 days; percentile 70.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 7.0.0-rc, .NET 6.0, .NET Core 3.1, and NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 7.0.0-rc.1, .NET 6.0, .NET Core 3.1, and NuGet clients (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol) where a malicious actor could cause a user to execute arbitrary code. Affected software NuGet & NuGet Packages - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 6.3.0 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 6.2.1 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 6.0.2 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.Protocol 5.11.2 version or earlier. - Any NuGet.exe,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g3q9-xf95-8hp5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-41032 Advisory: NuGet Elevation of Privilege Vulnerability IDs: CVE-2022-41032, GHSA-g3q9-xf95-8hp5 Record: https://patchnext.com/advisories/cve-2022-41032 (revision 1, source checked 26 Oct 2026, 17:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nuget.commands 6.3.1, 6.2.2, 6.0.3, 5.11.3, 5.9.3, 5.7.3, 4.9.6; nuget.commandline 6.3.1, 6.2.2, 6.0.3, 5.11.3, 5.9.3, 5.7.3, 4.9.6; nuget.protocol 6.3.1, 6.2.2, 6.0.3, 5.11.3, 5.9.3, 5.7.3, 4.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet nuget.commands: affected >= 4.6.0, < 4.9.6; >= 5.0.0, < 5.7.3; >= 5.8.0, < 5.9.3; >= 5.10.0, < 5.11.3; >= 6.0.0, < 6.0.3; >= 6.1.0, < 6.2.2; >= 6.3.0, < 6.3.1; fixed in 6.0.3, 4.9.6, 5.7.3, 5.11.3, 6.3.1, 6.2.2, 5.9.3 - NuGet nuget.commandline: affected >= 4.6.0, < 4.9.6; >= 5.0.0, < 5.7.3; >= 5.8.0, < 5.9.3; >= 5.10.0, < 5.11.3; >= 6.0.0, < 6.0.3; >= 6.1.0, < 6.2.2; >= 6.3.0, < 6.3.1; fixed in 6.0.3, 4.9.6, 5.7.3, 5.11.3, 6.3.1, 6.2.2, 5.9.3 - NuGet nuget.protocol: affected >= 4.6.0, < 4.9.6; >= 5.0.0, < 5.7.3; >= 5.8.0, < 5.9.3; >= 5.10.0, < 5.11.3; >= 6.0.0, < 6.0.3; >= 6.1.0, < 6.2.2; >= 6.3.0, < 6.3.1; fixed in 6.0.3, 4.9.6, 5.7.3, 5.11.3, 6.3.1, 6.2.2, 5.9.3 ## Suggested inspection (read-only) - NuGet nuget.commands: check the installed version with your package manager. - NuGet nuget.commandline: check the installed version with your package manager. - NuGet nuget.protocol: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nuget.commands, nuget.commandline, nuget.protocol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g3q9-xf95-8hp5 (GitHub-reviewed advisory GHSA-g3q9-xf95-8hp5 lists affected ranges: NuGet nuget.commands >=4.6.0 =5.0.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =6.3.0 =4.6.0 =5.0.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =6.3.0 =4.6.0 =5.0.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =6.3.0 <6.3.1) Commands are suggestions: review each one before running it.
Loading voting…