Potential leak of NuGet.org API key
CVE-2022-30184GHSA-3885-8gqc-3wpf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuget.commandline.xplat 6.2.1, 6.0.2, 5.11.2, 5.9.2, 5.7.2, 5.2.1, 4.9.5; nuget.commands 6.2.1, 6.0.2, 5.11.2, 5.9.2, 5.7.2, 5.2.1, 4.9.5; nuget.commandline 6.2.1, 6.0.2, 5.11.2, 5.9.2, 5.7.2, 5.2.1, 4.9.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet nuget.commandline.xplat
- Affected
- >= 3.5.0, < 4.9.5>= 5.0.0, < 5.2.1>= 5.3.0, < 5.7.2>= 5.8.0, < 5.9.2>= 5.10.0, < 5.11.2>= 6.0.0, < 6.0.2>= 6.1.0, < 6.2.1
- Fixed in
- 5.7.2, 5.2.1, 6.2.1, 5.9.2, 4.9.5, 5.11.2, 6.0.2
NuGet nuget.commands
- Affected
- >= 3.5.0, < 4.9.5>= 5.0.0, < 5.2.1>= 5.3.0, < 5.7.2>= 5.8.0, < 5.9.2>= 5.10.0, < 5.11.2>= 6.0.0, < 6.0.2>= 6.1.0, < 6.2.1
- Fixed in
- 5.7.2, 5.2.1, 6.2.1, 5.9.2, 4.9.5, 5.11.2, 6.0.2
NuGet nuget.commandline
- Affected
- >= 3.5.0, < 4.9.5>= 5.0.0, < 5.2.1>= 5.3.0, < 5.7.2>= 5.8.0, < 5.9.2>= 5.10.0, < 5.11.2>= 6.0.0, < 6.0.2>= 6.1.0, < 6.2.1
- Fixed in
- 5.7.2, 5.2.1, 6.2.1, 5.9.2, 4.9.5, 5.11.2, 6.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3885-8gqc-3wpf lists affected ranges: NuGet nuget.commands >=3.5.0 =5.0.0 =5.3.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =3.5.0 =5.0.0 =5.3.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =3.5.0 =5.0.0 =5.3.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 <6.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- EPSS
- CVE-2022-30184: 5.70% estimated exploitation activity in the next 30 days; percentile 93.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0 and .NET Core 3.1, NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat version range from 3.5.0 to 6.2.0). This advisory also provides guidance on what developers can do to update their applications to remove this vulnerability. A vulnerability exists in .NET 6.0, .NET Core 3.1, and NuGet (NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat version range from 3.5.0 to 6.2.0) where a nuget.org api key could leak due to an incorrect comparison with a server url. Affected software NuGet & NuGet Packages - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 6.2.0 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 6.0.1 version or earlier. - Any NuGet.exe, NuGet.Commands, NuGet.CommandLine, NuGet.CommandLine.XPlat 5.11.1 version or earlier. - Any NuGet.exe,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3885-8gqc-3wpf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-30184 Advisory: Potential leak of NuGet.org API key IDs: CVE-2022-30184, GHSA-3885-8gqc-3wpf Record: https://patchnext.com/advisories/cve-2022-30184 (revision 1, source checked 26 Oct 2026, 17:03 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nuget.commandline.xplat 6.2.1, 6.0.2, 5.11.2, 5.9.2, 5.7.2, 5.2.1, 4.9.5; nuget.commands 6.2.1, 6.0.2, 5.11.2, 5.9.2, 5.7.2, 5.2.1, 4.9.5; nuget.commandline 6.2.1, 6.0.2, 5.11.2, 5.9.2, 5.7.2, 5.2.1, 4.9.5. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet nuget.commandline.xplat: affected >= 3.5.0, < 4.9.5; >= 5.0.0, < 5.2.1; >= 5.3.0, < 5.7.2; >= 5.8.0, < 5.9.2; >= 5.10.0, < 5.11.2; >= 6.0.0, < 6.0.2; >= 6.1.0, < 6.2.1; fixed in 5.7.2, 5.2.1, 6.2.1, 5.9.2, 4.9.5, 5.11.2, 6.0.2 - NuGet nuget.commands: affected >= 3.5.0, < 4.9.5; >= 5.0.0, < 5.2.1; >= 5.3.0, < 5.7.2; >= 5.8.0, < 5.9.2; >= 5.10.0, < 5.11.2; >= 6.0.0, < 6.0.2; >= 6.1.0, < 6.2.1; fixed in 5.7.2, 5.2.1, 6.2.1, 5.9.2, 4.9.5, 5.11.2, 6.0.2 - NuGet nuget.commandline: affected >= 3.5.0, < 4.9.5; >= 5.0.0, < 5.2.1; >= 5.3.0, < 5.7.2; >= 5.8.0, < 5.9.2; >= 5.10.0, < 5.11.2; >= 6.0.0, < 6.0.2; >= 6.1.0, < 6.2.1; fixed in 5.7.2, 5.2.1, 6.2.1, 5.9.2, 4.9.5, 5.11.2, 6.0.2 ## Suggested inspection (read-only) - NuGet nuget.commandline.xplat: check the installed version with your package manager. - NuGet nuget.commands: check the installed version with your package manager. - NuGet nuget.commandline: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nuget.commandline.xplat, nuget.commands, nuget.commandline. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3885-8gqc-3wpf (GitHub-reviewed advisory GHSA-3885-8gqc-3wpf lists affected ranges: NuGet nuget.commands >=3.5.0 =5.0.0 =5.3.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =3.5.0 =5.0.0 =5.3.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 =3.5.0 =5.0.0 =5.3.0 =5.8.0 =5.10.0 =6.0.0 =6.1.0 <6.2.1) Commands are suggestions: review each one before running it.
Loading voting…