Skip to content

← Actionable
Critical, CVSS 9.1

NuGet Client Security Feature Bypass Vulnerability

CVE-2024-0057GHSA-68w7-72jg-6qpp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuget.commandline 6.8.1, 6.7.1, 6.6.2, 6.4.3, 6.3.4, 6.0.6, 5.11.6; nuget.packaging 6.8.1, 6.7.1, 6.6.2, 6.4.3, 6.3.4, 6.0.6, 5.11.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet nuget.commandline

    Affected
    >= 4.6.0, < 5.11.6>= 6.0.0, < 6.0.6>= 6.3.0, < 6.3.4>= 6.4.0, < 6.4.3>= 6.6.0, < 6.6.2>= 6.7.0, <= 6.7.0>= 6.8.0, <= 6.8.0
    Fixed in
    5.11.6, 6.6.2, 6.8.1, 6.3.4, 6.7.1, 6.4.3, 6.0.6
  • NuGet nuget.packaging

    Affected
    >= 4.6.0, < 5.11.6>= 6.0.0, < 6.0.6>= 6.3.0, < 6.3.4>= 6.4.0, < 6.4.3>= 6.6.0, < 6.6.2>= 6.7.0, <= 6.7.0>= 6.8.0, <= 6.8.0
    Fixed in
    5.11.6, 6.6.2, 6.8.1, 6.3.4, 6.7.1, 6.4.3, 6.0.6

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-68w7-72jg-6qpp lists affected ranges: NuGet nuget.commandline >=4.6.0 =6.0.0 =6.3.0 =6.4.0 =6.6.0 =6.7.0 =6.8.0 =4.6.0 =6.0.0 =6.3.0 =6.4.0 =6.6.0 =6.7.0 =6.8.0 <=6.8.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2024-0057: 2.78% estimated exploitation activity in the next 30 days; percentile 86.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Microsoft is releasing this security advisory to provide information about a vulnerability in .NET 6.0, .NET 7.0 and .NET 8.0. This advisory also provides guidance on what developers can do to update their applications to address this vulnerability. A security feature bypass vulnerability exists when Microsoft .NET Framework-based applications use X.509 chain building APIs but do not completely validate the X.509 certificate due to a logic flaw. An attacker could present an arbitrary untrusted certificate with malformed signatures, triggering a bug in the framework. The framework will correctly report that X.509 chain building failed, but it will return an incorrect reason code for the failure. Applications which utilize this reason code to make their own chain building trust decisions may inadvertently treat this scenario as a successful chain build. This could allow an adversary to subvert the app's typical authentication logic. Affected software NuGet & NuGet Packages…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-68w7-72jg-6qpp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-0057

Advisory: NuGet Client Security Feature Bypass Vulnerability
IDs: CVE-2024-0057, GHSA-68w7-72jg-6qpp
Record: https://patchnext.com/advisories/cve-2024-0057 (revision 1, source checked 26 Oct 2026, 17:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nuget.commandline 6.8.1, 6.7.1, 6.6.2, 6.4.3, 6.3.4, 6.0.6, 5.11.6; nuget.packaging 6.8.1, 6.7.1, 6.6.2, 6.4.3, 6.3.4, 6.0.6, 5.11.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet nuget.commandline: affected >= 4.6.0, < 5.11.6; >= 6.0.0, < 6.0.6; >= 6.3.0, < 6.3.4; >= 6.4.0, < 6.4.3; >= 6.6.0, < 6.6.2; >= 6.7.0, <= 6.7.0; >= 6.8.0, <= 6.8.0; fixed in 5.11.6, 6.6.2, 6.8.1, 6.3.4, 6.7.1, 6.4.3, 6.0.6
- NuGet nuget.packaging: affected >= 4.6.0, < 5.11.6; >= 6.0.0, < 6.0.6; >= 6.3.0, < 6.3.4; >= 6.4.0, < 6.4.3; >= 6.6.0, < 6.6.2; >= 6.7.0, <= 6.7.0; >= 6.8.0, <= 6.8.0; fixed in 5.11.6, 6.6.2, 6.8.1, 6.3.4, 6.7.1, 6.4.3, 6.0.6

## Suggested inspection (read-only)
- NuGet nuget.commandline: check the installed version with your package manager.
- NuGet nuget.packaging: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nuget.commandline, nuget.packaging.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-68w7-72jg-6qpp (GitHub-reviewed advisory GHSA-68w7-72jg-6qpp lists affected ranges: NuGet nuget.commandline >=4.6.0 =6.0.0 =6.3.0 =6.4.0 =6.6.0 =6.7.0 =6.8.0 =4.6.0 =6.0.0 =6.3.0 =6.4.0 =6.6.0 =6.7.0 =6.8.0 <=6.8.0)

Commands are suggestions: review each one before running it.

Loading voting…