Defense in Depth update for NuGet Client
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuget.commandline 7.3.1, 7.0.3, 6.14.3, 6.12.5, 6.11.2, 6.8.2, 5.11.7, 4.9.7; nuget.packaging 7.3.1, 7.0.3, 6.14.3, 6.12.5, 6.11.2, 6.8.2, 5.11.7, 4.9.7; nuget.protocol 7.3.1, 7.0.3, 6.14.3, 6.12.5, 6.11.2, 6.8.2, 5.11.7, 4.9.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
NuGet nuget.commandline
- Affected
- >= 4.9.0, <= 4.9.6>= 5.11.0, <= 5.11.6>= 6.8.0, <= 6.8.1>= 6.11.0, <= 6.11.1>= 6.12.0, <= 6.12.4>= 6.14.0, <= 6.14.2>= 7.0.0, <= 7.0.2>= 7.3.0, <= 7.3.0
- Fixed in
- 5.11.7, 6.14.3, 6.11.2, 6.12.5, 7.3.1, 6.8.2, 4.9.7, 7.0.3
NuGet nuget.packaging
- Affected
- >= 4.9.0, <= 4.9.6>= 5.11.0, <= 5.11.6>= 6.8.0, <= 6.8.1>= 6.11.0, <= 6.11.1>= 6.12.0, <= 6.12.4>= 6.14.0, <= 6.14.2>= 7.0.0, <= 7.0.2>= 7.3.0, <= 7.3.0
- Fixed in
- 5.11.7, 6.14.3, 6.11.2, 6.12.5, 7.3.1, 6.8.2, 4.9.7, 7.0.3
NuGet nuget.protocol
- Affected
- >= 4.9.0, <= 4.9.6>= 5.11.0, <= 5.11.6>= 6.8.0, <= 6.8.1>= 6.11.0, <= 6.11.1>= 6.12.0, <= 6.12.4>= 6.14.0, <= 6.14.2>= 7.0.0, <= 7.0.2>= 7.3.0, <= 7.3.0
- Fixed in
- 5.11.7, 6.14.3, 6.11.2, 6.12.5, 7.3.1, 6.8.2, 4.9.7, 7.0.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g4vj-cjjj-v7hg lists affected ranges: NuGet nuget.packaging >=4.9.0 =5.11.0 =6.8.0 =6.11.0 =6.12.0 =6.14.0 =7.0.0 =7.3.0 =4.9.0 =5.11.0 =6.8.0 =6.11.0 =6.12.0 =6.14.0 =7.0.0 =7.3.0 =4.9.0 =5.11.0 =6.8.0 =6.11.0 <=6.11.1,…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact This update adds validation of the package ID and version during package download, in addition to the existing package signature validation. Patches NuGet The following NuGet.exe, NuGet.CommandLine, NuGet.Packaging, and NuGet.Protocol versions have been patched: |Affected versions|Patched version| |--|--| |= 4.9.0, <= 4.9.6|4.9.7| |= 5.11.0, <= 5.11.6|5.11.7| |= 6.8.0, <= 6.8.1|6.8.2| |= 6.11.0, <= 6.11.1|6.11.2| |= 6.12.0, <= 6.12.4|6.12.5| |= 6.14.0, <= 6.14.2|6.14.3| |= 7.0.0, <= 7.0.2|7.0.3| |7.3.0|7.3.1| .NET SDK .NET 8.0.126 SDK .NET 8.0.420 SDK .NET 9.0.116 SDK .NET 9.0.313 SDK .NET 10.0.106 SDK .NET 10.0.202 SDK Workarounds N/A References https://github.com/NuGet/NuGetGallery/security/advisories/GHSA-9r3h-v4hx-rhfr Credit splitline with DEVCORE
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g4vj-cjjj-v7hg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-g4vj-cjjj-v7hg Advisory: Defense in Depth update for NuGet Client IDs: GHSA-g4vj-cjjj-v7hg Record: https://patchnext.com/advisories/ghsa-g4vj-cjjj-v7hg (revision 1, source checked 26 Oct 2026, 17:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nuget.commandline 7.3.1, 7.0.3, 6.14.3, 6.12.5, 6.11.2, 6.8.2, 5.11.7, 4.9.7; nuget.packaging 7.3.1, 7.0.3, 6.14.3, 6.12.5, 6.11.2, 6.8.2, 5.11.7, 4.9.7; nuget.protocol 7.3.1, 7.0.3, 6.14.3, 6.12.5, 6.11.2, 6.8.2, 5.11.7, 4.9.7. A vendor fix does not mean a deployment is fixed. ## Affected components - NuGet nuget.commandline: affected >= 4.9.0, <= 4.9.6; >= 5.11.0, <= 5.11.6; >= 6.8.0, <= 6.8.1; >= 6.11.0, <= 6.11.1; >= 6.12.0, <= 6.12.4; >= 6.14.0, <= 6.14.2; >= 7.0.0, <= 7.0.2; >= 7.3.0, <= 7.3.0; fixed in 5.11.7, 6.14.3, 6.11.2, 6.12.5, 7.3.1, 6.8.2, 4.9.7, 7.0.3 - NuGet nuget.packaging: affected >= 4.9.0, <= 4.9.6; >= 5.11.0, <= 5.11.6; >= 6.8.0, <= 6.8.1; >= 6.11.0, <= 6.11.1; >= 6.12.0, <= 6.12.4; >= 6.14.0, <= 6.14.2; >= 7.0.0, <= 7.0.2; >= 7.3.0, <= 7.3.0; fixed in 5.11.7, 6.14.3, 6.11.2, 6.12.5, 7.3.1, 6.8.2, 4.9.7, 7.0.3 - NuGet nuget.protocol: affected >= 4.9.0, <= 4.9.6; >= 5.11.0, <= 5.11.6; >= 6.8.0, <= 6.8.1; >= 6.11.0, <= 6.11.1; >= 6.12.0, <= 6.12.4; >= 6.14.0, <= 6.14.2; >= 7.0.0, <= 7.0.2; >= 7.3.0, <= 7.3.0; fixed in 5.11.7, 6.14.3, 6.11.2, 6.12.5, 7.3.1, 6.8.2, 4.9.7, 7.0.3 ## Suggested inspection (read-only) - NuGet nuget.commandline: check the installed version with your package manager. - NuGet nuget.packaging: check the installed version with your package manager. - NuGet nuget.protocol: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nuget.commandline, nuget.packaging, nuget.protocol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g4vj-cjjj-v7hg (GitHub-reviewed advisory GHSA-g4vj-cjjj-v7hg lists affected ranges: NuGet nuget.packaging >=4.9.0 =5.11.0 =6.8.0 =6.11.0 =6.12.0 =6.14.0 =7.0.0 =7.3.0 =4.9.0 =5.11.0 =6.8.0 =6.11.0 =6.12.0 =6.14.0 =7.0.0 =7.3.0 =4.9.0 =5.11.0 =6.8.0 =6.11.0 <=6.11.1,…) Commands are suggestions: review each one before running it.
Loading voting…