Skip to content

← Public intelligence

npm package

ckeditor5

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 3.1npmAmendedPublished

    CKEditor: Cross-site scripting (XSS) in the engine package

    CVE-2026-116687 · GHSA-v6mg-96c6-gmpq

    Affected
    • npm ckeditor5 >= 29.0.0, < 47.7.4; >= 48.0.0, < 48.5.1
    Fixed in
    48.5.147.7.4· Vendor fix available
    Issue
    Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor. This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content. Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS). For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

    Recommended action: Upgrade to 48.5.1 or 47.7.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  2. High, CVSS 8.1npmAmendedPublished

    CKEditor: Cross-site scripting (XSS) in the engine package

    CVE-2026-116688 · GHSA-rh54-vffm-5fvp

    Affected
    • npm ckeditor5 >= 45.0.0, < 47.7.4; >= 48.0.0, < 48.5.1
    Fixed in
    48.5.147.7.4· Vendor fix available
    Issue
    Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the `es-toolkit` library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming `style` attribute values. The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5. Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS). For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

    Recommended action: Upgrade to 48.5.1 or 47.7.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.com (1)osv.dev (2)Source checked Evidence →
  3. Medium, CVSS 6.4npmAmendedPublished

    CKEditor 5 has Cross-site Scripting (XSS) in the HTML Support package

    CVE-2026-28343 · GHSA-jrqm-vmqc-gm93

    Affected
    • npm ckeditor5 >= 29.0.0, < 47.6.0
    Fixed in
    47.6.0· Vendor fix available
    Issue
    Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the General HTML Support feature. This vulnerability could be triggered by inserting specially crafted markup, leading to unauthorized JavaScript code execution, if the editor instance used an unsafe General HTML Support configuration. This vulnerability affects only installations where the editor configuration meets the following criteria: General HTML Support is enabled, General HTML Support configuration allows inserting unsafe markup (see Security section to learn more). Patches The problem has been recognized and patched. The fix will be available in version 47.6.0 (and above). Workarounds CKEditor 5 recommends configuring General HTML Support securely to ensure that unsafe content is not accepted. Please refer to the Security section for detailed guidance. Credits CKEditor 5 would like to thank: - Emilio Kevin - Jeongwoo Lee, Younsoung Kim, Minseok Kim and Jinyeong Kim from ENKI Whitehat for responsibly…

    Recommended action: Upgrade to 47.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Low, CVSS 2.3npmAmendedPublished

    CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package

    CVE-2025-58064 · GHSA-x9gp-vjh6-3wv6

    Affected
    • npm ckeditor5 >= 46.0.0, < 46.0.3; >= 44.2.0, < 45.2.2
    Fixed in
    46.0.345.2.2· Vendor fix available
    Issue
    Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets one of the following criteria: - HTML embed plugin is enabled - Custom plugin introducing editable element which implements view RawElement is enabled Patches The problem has been recognized and patched. The fix will be available in version 46.0.3 (and above), and explicitly in version 45.2.2. For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

    Recommended action: Upgrade to 46.0.3 or 45.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. Medium, CVSS 5.1npmAmendedPublished

    Cross-site scripting (XSS) in the clipboard package

    CVE-2024-45613 · GHSA-rgg8-g5x8-wr9v

    Affected
    • npm ckeditor5 >= 40.0.0, < 43.1.1
    Fixed in
    43.1.1· Vendor fix available
    Issue
    Impact During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets the following criteria: 1. The Block Toolbar plugin is enabled. 1. One of the following plugins is also enabled: - General HTML Support with a configuration that permits unsafe markup. - HTML Embed. Patches The problem has been recognized and patched. The fix will be available in version 43.1.1 (and above), and explicitly in version 41.3.2. Workarounds It's highly recommended to update to the version 43.1.1 or higher. However, if the update is not an option, we recommend disabling the block toolbar plugin. For more information…

    Recommended action: Upgrade to 43.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →