Skip to content

← Actionable
Low, CVSS 2.3amended

CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package

CVE-2025-58064GHSA-x9gp-vjh6-3wv6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor5 46.0.3, 45.2.2; @ckeditor/ckeditor5-clipboard 46.0.3, 45.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
EPSS
  • CVE-2025-58064: 0.42% estimated exploitation activity in the next 30 days; percentile 36.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets one of the following criteria: - HTML embed plugin is enabled - Custom plugin introducing editable element which implements view RawElement is enabled Patches The problem has been recognized and patched. The fix will be available in version 46.0.3 (and above), and explicitly in version 45.2.2. For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-x9gp-vjh6-3wv6

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-x9gp-vjh6-3wv6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-58064

Advisory: CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package
IDs: CVE-2025-58064, GHSA-x9gp-vjh6-3wv6
Record: https://patchnext.com/advisories/cve-2025-58064 (revision 3, source checked 26 Oct 2026, 12:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckeditor5 46.0.3, 45.2.2; @ckeditor/ckeditor5-clipboard 46.0.3, 45.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ckeditor5: affected >= 46.0.0, < 46.0.3; >= 44.2.0, < 45.2.2; fixed in 46.0.3, 45.2.2
- npm @ckeditor/ckeditor5-clipboard: affected >= 44.2.0, < 45.2.2; >= 46.0.0, < 46.0.3; fixed in 46.0.3, 45.2.2

## Suggested inspection (read-only)
- `npm ls ckeditor5 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-clipboard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckeditor5, @ckeditor/ckeditor5-clipboard.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x9gp-vjh6-3wv6 (OSV record GHSA-x9gp-vjh6-3wv6 lists affected ranges: npm ckeditor5 >=46.0.0 =44.2.0 =44.2.0 =46.0.0 <46.0.3 (fixed))
- Verified: https://github.com/advisories/GHSA-x9gp-vjh6-3wv6 (GitHub-reviewed advisory GHSA-x9gp-vjh6-3wv6 lists affected ranges: npm ckeditor5 >=46.0.0 =44.2.0 =44.2.0 =46.0.0 <46.0.3)

Commands are suggestions: review each one before running it.

Loading voting…