Skip to content

← Public intelligence

npm package

@ckeditor/ckeditor5-clipboard

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.3npmAmendedPublished

    CKEditor 5 cross-site scripting (XSS) vulnerability in the clipboard package

    CVE-2025-58064 · GHSA-x9gp-vjh6-3wv6

    Affected
    • npm @ckeditor/ckeditor5-clipboard >= 44.2.0, < 45.2.2; >= 46.0.0, < 46.0.3
    Fixed in
    46.0.345.2.2· Vendor fix available
    Issue
    Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets one of the following criteria: - HTML embed plugin is enabled - Custom plugin introducing editable element which implements view RawElement is enabled Patches The problem has been recognized and patched. The fix will be available in version 46.0.3 (and above), and explicitly in version 45.2.2. For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

    Recommended action: Upgrade to 46.0.3 or 45.2.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.1npmAmendedPublished

    Cross-site scripting (XSS) in the clipboard package

    CVE-2024-45613 · GHSA-rgg8-g5x8-wr9v

    Affected
    • npm @ckeditor/ckeditor5-clipboard >= 40.0.0, < 43.1.1
    Fixed in
    43.1.1· Vendor fix available
    Issue
    Impact During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets the following criteria: 1. The Block Toolbar plugin is enabled. 1. One of the following plugins is also enabled: - General HTML Support with a configuration that permits unsafe markup. - HTML Embed. Patches The problem has been recognized and patched. The fix will be available in version 43.1.1 (and above), and explicitly in version 41.3.2. Workarounds It's highly recommended to update to the version 43.1.1 or higher. However, if the update is not an option, we recommend disabling the block toolbar plugin. For more information…

    Recommended action: Upgrade to 43.1.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →