Cross-site scripting (XSS) in the clipboard package
CVE-2024-45613GHSA-rgg8-g5x8-wr9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor5 43.1.1; @ckeditor/ckeditor5-clipboard 43.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ckeditor5
- Affected
- >= 40.0.0, < 43.1.1
- Fixed in
- 43.1.1
npm @ckeditor/ckeditor5-clipboard
- Affected
- >= 40.0.0, < 43.1.1
- Fixed in
- 43.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rgg8-g5x8-wr9v lists affected ranges: npm ckeditor5 >=40.0.0 =40.0.0 <43.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rgg8-g5x8-wr9v lists affected ranges: npm ckeditor5 >=40.0.0 =40.0.0 <43.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2024-45613: 0.52% estimated exploitation activity in the next 30 days; percentile 44.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 clipboard package. This vulnerability could be triggered by a specific user action, leading to unauthorized JavaScript code execution, if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects only installations where the editor configuration meets the following criteria: 1. The Block Toolbar plugin is enabled. 1. One of the following plugins is also enabled: - General HTML Support with a configuration that permits unsafe markup. - HTML Embed. Patches The problem has been recognized and patched. The fix will be available in version 43.1.1 (and above), and explicitly in version 41.3.2. Workarounds It's highly recommended to update to the version 43.1.1 or higher. However, if the update is not an option, we recommend disabling the block toolbar plugin. For more information…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-rgg8-g5x8-wr9v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-rgg8-g5x8-wr9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-45613 Advisory: Cross-site scripting (XSS) in the clipboard package IDs: CVE-2024-45613, GHSA-rgg8-g5x8-wr9v Record: https://patchnext.com/advisories/cve-2024-45613 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckeditor5 43.1.1; @ckeditor/ckeditor5-clipboard 43.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ckeditor5: affected >= 40.0.0, < 43.1.1; fixed in 43.1.1 - npm @ckeditor/ckeditor5-clipboard: affected >= 40.0.0, < 43.1.1; fixed in 43.1.1 ## Suggested inspection (read-only) - `npm ls ckeditor5 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @ckeditor/ckeditor5-clipboard --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckeditor5, @ckeditor/ckeditor5-clipboard. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rgg8-g5x8-wr9v (OSV record GHSA-rgg8-g5x8-wr9v lists affected ranges: npm ckeditor5 >=40.0.0 =40.0.0 <43.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rgg8-g5x8-wr9v (GitHub-reviewed advisory GHSA-rgg8-g5x8-wr9v lists affected ranges: npm ckeditor5 >=40.0.0 =40.0.0 <43.1.1) Commands are suggestions: review each one before running it.
Loading voting…