Skip to content

← Actionable
High, CVSS 8.1amended

CKEditor: Cross-site scripting (XSS) in the engine package

CVE-2026-116688GHSA-rh54-vffm-5fvp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckeditor5 48.5.1, 47.7.4; @ckeditor/ckeditor5-engine 48.5.1, 47.7.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ckeditor5

    Affected
    >= 45.0.0, < 47.7.4>= 48.0.0, < 48.5.1
    Fixed in
    48.5.1, 47.7.4
  • npm @ckeditor/ckeditor5-engine

    Affected
    >= 45.0.0, < 47.7.4>= 48.0.0, < 48.5.1
    Fixed in
    48.5.1, 47.7.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-116688: 0.50% estimated exploitation activity in the next 30 days; percentile 42.71 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the `es-toolkit` library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming `style` attribute values. The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.

Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS).

For more information Email us at security@cksource.com if you have any questions or comments about this advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-rh54-vffm-5fvp

  2. Revision 1 · created ·

    Published from ghsa record GHSA-rh54-vffm-5fvp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-116688

Advisory: CKEditor: Cross-site scripting (XSS) in the engine package
IDs: CVE-2026-116688, GHSA-rh54-vffm-5fvp
Record: https://patchnext.com/advisories/cve-2026-116688 (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ckeditor5 48.5.1, 47.7.4; @ckeditor/ckeditor5-engine 48.5.1, 47.7.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ckeditor5: affected >= 45.0.0, < 47.7.4; >= 48.0.0, < 48.5.1; fixed in 48.5.1, 47.7.4
- npm @ckeditor/ckeditor5-engine: affected >= 45.0.0, < 47.7.4; >= 48.0.0, < 48.5.1; fixed in 48.5.1, 47.7.4

## Suggested inspection (read-only)
- `npm ls ckeditor5 --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-engine --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ckeditor5, @ckeditor/ckeditor5-engine.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rh54-vffm-5fvp (GitHub-reviewed advisory GHSA-rh54-vffm-5fvp lists affected ranges: npm ckeditor5 >=45.0.0 =48.0.0 =45.0.0 =48.0.0 <48.5.1)
- Verified: https://osv.dev/vulnerability/GHSA-rh54-vffm-5fvp (OSV record GHSA-rh54-vffm-5fvp lists affected ranges: npm ckeditor5 >=45.0.0 =48.0.0 =45.0.0 =48.0.0 <48.5.1 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…