Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.
Open advisories
3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.
Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor. This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content. Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS). For more information Email us at security@cksource.com if you have any questions or comments about this advisory.
Recommended action: Upgrade to 48.5.1 or 47.7.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the `es-toolkit` library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming `style` attribute values. The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5. Patches The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS). For more information Email us at security@cksource.com if you have any questions or comments about this advisory.
Recommended action: Upgrade to 48.5.1 or 47.7.4 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Impact A regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. Patches The problem has been recognized and patched. The fix will be available in version 27.0.0. For more information Email us at security@cksource.com if you have any questions or comments about this advisory. Acknowledgements The CKEditor 5 team would like to thank Yeting Li for recognizing and reporting these vulnerabilities.
Recommended action: Upgrade to 27.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.