Skip to content

← Actionable
Medium, CVSS 6.5amended

Regular expression Denial of Service in multiple packages

CVE-2021-21391GHSA-3rh3-wfr4-76mj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@ckeditor/ckeditor5-font 27.0.0; @ckeditor/ckeditor5-markdown-gfm 27.0.0; @ckeditor/ckeditor5-list 27.0.0; @ckeditor/ckeditor5-paste-from-office 27.0.0; @ckeditor/ckeditor5-widget 27.0.0; 3 more packages under Affected packages), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
  • CVE-2021-21391: 1.67% estimated exploitation activity in the next 30 days; percentile 76.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. Patches The problem has been recognized and patched. The fix will be available in version 27.0.0. For more information Email us at security@cksource.com if you have any questions or comments about this advisory. Acknowledgements The CKEditor 5 team would like to thank Yeting Li for recognizing and reporting these vulnerabilities.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3rh3-wfr4-76mj

  2. Revision 1 · created ·

    Published from osv record GHSA-3rh3-wfr4-76mj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21391

Advisory: Regular expression Denial of Service in multiple packages
IDs: CVE-2021-21391, GHSA-3rh3-wfr4-76mj
Record: https://patchnext.com/advisories/cve-2021-21391 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @ckeditor/ckeditor5-font 27.0.0; @ckeditor/ckeditor5-markdown-gfm 27.0.0; @ckeditor/ckeditor5-list 27.0.0; @ckeditor/ckeditor5-paste-from-office 27.0.0; @ckeditor/ckeditor5-widget 27.0.0; @ckeditor/ckeditor5-media-embed 27.0.0; @ckeditor/ckeditor5-image 27.0.0; @ckeditor/ckeditor5-engine 27.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @ckeditor/ckeditor5-font: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-markdown-gfm: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-list: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-paste-from-office: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-widget: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-media-embed: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-image: affected <= 26.0.0; fixed in 27.0.0
- npm @ckeditor/ckeditor5-engine: affected <= 26.0.0; fixed in 27.0.0

## Suggested inspection (read-only)
- `npm ls @ckeditor/ckeditor5-font --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-markdown-gfm --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-list --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-paste-from-office --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-widget --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-media-embed --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-image --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @ckeditor/ckeditor5-engine --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @ckeditor/ckeditor5-font, @ckeditor/ckeditor5-markdown-gfm, @ckeditor/ckeditor5-list, @ckeditor/ckeditor5-paste-from-office, @ckeditor/ckeditor5-widget, @ckeditor/ckeditor5-media-embed, @ckeditor/ckeditor5-image, @ckeditor/ckeditor5-engine.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3rh3-wfr4-76mj (OSV record GHSA-3rh3-wfr4-76mj lists affected ranges: npm @ckeditor/ckeditor5-engine >=0 =0 =0 =0 =0 =0 =0 =0 <27.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3rh3-wfr4-76mj (GitHub-reviewed advisory GHSA-3rh3-wfr4-76mj lists affected ranges: npm @ckeditor/ckeditor5-engine >=0 =0 =0 =0 =0 =0 =0 =0 <=26.0.0)

Commands are suggestions: review each one before running it.

Loading voting…